Bug 442114 - No PackageKit icon for reverted packages
No PackageKit icon for reverted packages
Status: CLOSED DUPLICATE of bug 442302
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-11 15:53 EDT by Tom London
Modified: 2008-04-14 07:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 07:26:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom London 2008-04-11 15:53:30 EDT
Description of problem:
[Not sure this is really a bug.....]
If you revert a previously updated package, PackageKit no longer prompts you to
update.

For example, I had to revert xorg-x11-server packages from -21 to -18 to get
compiz working again.

Afterwards, for example after numerous reboots, PackageKit does not "remind me"
that xorg-x11-server-Xorg and -common need updates.

Is that expected behavior?

Version-Release number of selected component (if applicable):
PackageKit-0.1.11-1.fc9.i386

How reproducible:
yes

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Richard Hughes 2008-04-12 05:37:34 EDT
How did you revert the packages? This thing should be caught on your next Check
for updates - so if you only specified daily then it's only done every 24h. Can
you explain exactly what you did please.
Comment 2 Tom London 2008-04-12 11:37:34 EDT
Sure. After updating the system, compiz no longer worked.

I reverted to older versions of xorg-x11-server-common and xorg-x11-server-Xorg
(the -18 versions) by running "rpm -Uvh --oldpackage ...." in my
/var/cache/yum/rawhide/packages directory.  [Is there some "better" way to revert?]

When I reboot, the nice "orange alert icon" does not appear.

Since I am working a BZ on xorg-x11-server, I can not be 100% certain that I ran
for 24 hours without updating again to test.

However, this morning when I booted, PackageKit told me about 10 updates (not
xorg-x11-server).  However, I think it found it in the 'dependency search', as
it looks like it got updated:

Apr 12 08:29:44 Updated: cairo-1.6.4-1.fc9.i386
Apr 12 08:29:45 Updated: libvolume_id-120-3.fc9.i386
Apr 12 08:29:48 Updated: udev-120-3.fc9.i386
Apr 12 08:29:49 Updated: nash-6.0.45-1.fc9.i386
Apr 12 08:29:50 Updated: libbdevid-python-6.0.45-1.fc9.i386
Apr 12 08:29:51 Updated: mkinitrd-6.0.45-1.fc9.i386
Apr 12 08:30:22 Installed: gnome-packagekit-0.1.11-5.fc9.i386
Apr 12 08:30:26 Updated: kvm-65-1.fc9.i386
Apr 12 08:30:27 Updated: xorg-x11-server-common-1.4.99.901-21.20080407.fc9.i386
Apr 12 08:30:31 Updated: firstboot-1.96-1.fc9.i386
Apr 12 08:30:46 Updated: fedora-logos-9.0.0-1.fc9.noarch
Apr 12 08:30:50 Updated: system-config-keyboard-1.2.14-3.fc9.noarch
Apr 12 08:30:54 Updated: cairo-devel-1.6.4-1.fc9.i386
Apr 12 08:30:58 Updated: desktop-backgrounds-basic-9.0.0-1.noarch
Apr 12 08:30:59 Updated: fedora-release-8.93-1.noarch
Apr 12 08:31:23 Updated: 1:gdm-2.21.10-0.2008.04.11.3.fc9.i386
Apr 12 08:31:30 Updated: xorg-x11-server-Xorg-1.4.99.901-21.20080407.fc9.i386
Apr 12 08:31:31 Updated: 1:gdm-user-switch-applet-2.21.10-0.2008.04.11.3.fc9.i386
Apr 12 08:31:52 Erased: pirut
Comment 3 Tom London 2008-04-13 12:04:00 EDT
Here is slightly different 'use case':

I login and get the 'orange icon' informing me I have 3 updates.

Instead of using PackageKit to do the update, I use 'yum --exclude=xorg\*' (to
avoid the apparently broken xorg-x11-server packages).

When yum completes, the nice orange icon is gone. 

BTW, one of the updates was for PackageKit:

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 PackageKit              i386       0.1.12-1.20080412git.fc9  rawhide          
343 k
 PackageKit-libs         i386       0.1.12-1.20080412git.fc9  rawhide          
 93 k
 glibc                   i686       2.8-1            rawhide           5.5 M
 glibc-common            i386       2.8-1            rawhide            21 M
 glibc-debuginfo         i686       2.8-1            rawhide-debuginfo  8.7 M
 glibc-debuginfo-common  i386       2.8-1            rawhide-debuginfo   13 M
 glibc-devel             i386       2.8-1            rawhide           2.1 M
 glibc-headers           i386       2.8-1            rawhide           611 k
 gnome-packagekit        i386       0.1.12-1.20080412git.fc9  rawhide          
569 k
 nscd                    i386       2.8-1            rawhide           179 k
 yum-packagekit          i386       0.1.12-1.20080412git.fc9  rawhide          
6.7 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update      11 Package(s)         
Remove       0 Package(s)         

Total download size: 52 M
Is this ok [y/N]: y
Downloading Packages:
Downloading DeltaRPMs:
Rebuilding rpms from deltarpms
(1/11): gnome-packagekit-0.1.12-1.20080412git.fc9.i386.r | 569 kB     00:00     
(2/11): yum-packagekit-0.1.12-1.20080412git.fc9.i386.rpm | 6.7 kB     00:00    
(3/11): glibc-debuginfo-common-2.8-1.i386.rpm            |  13 MB     00:08     
(4/11): PackageKit-libs-0.1.12-1.20080412git.fc9.i386.rp |  93 kB     00:00    
(5/11): glibc-common-2.8-1.i386.rpm                      |  21 MB     00:25     
(6/11): glibc-debuginfo-2.8-1.i686.rpm                   | 8.7 MB     00:11     
(7/11): glibc-headers-2.8-1.i386.rpm                     | 611 kB     00:00     
(8/11): glibc-devel-2.8-1.i386.rpm                       | 2.1 MB     00:02     
(9/11): nscd-2.8-1.i386.rpm                              | 179 kB     00:00    
(10/11): glibc-2.8-1.i686.rpm                            | 5.5 MB     00:07     
(11/11): PackageKit-0.1.12-1.20080412git.fc9.i386.rpm    | 343 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating  : glibc-debuginfo-common       ####################### [ 1/22] 
  Updating  : glibc-debuginfo              ####################### [ 2/22] 
  Updating  : glibc                        ####################### [ 3/22] 
  Updating  : glibc-common                 ####################### [ 4/22] 
  Updating  : glibc-headers                ####################### [ 5/22] 
  Updating  : yum-packagekit               ####################### [ 6/22] 
  Updating  : glibc-devel                  ####################### [ 7/22] 
  Updating  : nscd                         ####################### [ 8/22] 
  Updating  : PackageKit-libs              ####################### [ 9/22] 
  Updating  : PackageKit                   ####################### [10/22] 
  Updating  : gnome-packagekit             ####################### [11/22] 
  Cleanup   : PackageKit                   ####################### [12/22] 
  Cleanup   : glibc                        ####################### [13/22] 
  Cleanup   : nscd                         ####################### [14/22] 
  Cleanup   : glibc-devel                  ####################### [15/22] 
  Cleanup   : glibc-headers                ####################### [16/22] 
  Cleanup   : glibc-debuginfo              ####################### [17/22] 
  Cleanup   : glibc-common                 ####################### [18/22] 
  Cleanup   : PackageKit-libs              ####################### [19/22] 
  Cleanup   : glibc-debuginfo-common       ####################### [20/22] 
  Cleanup   : yum-packagekit               ####################### [21/22] 
  Cleanup   : gnome-packagekit             ####################### [22/22] 

Updated: PackageKit.i386 0:0.1.12-1.20080412git.fc9 PackageKit-libs.i386
0:0.1.12-1.20080412git.fc9 glibc.i686 0:2.8-1 glibc-common.i386 0:2.8-1
glibc-debuginfo.i686 0:2.8-1 glibc-debuginfo-common.i386 0:2.8-1
glibc-devel.i386 0:2.8-1 glibc-headers.i386 0:2.8-1 gnome-packagekit.i386
0:0.1.12-1.20080412git.fc9 nscd.i386 0:2.8-1 yum-packagekit.i386
0:0.1.12-1.20080412git.fc9
Complete!
[root@localhost ~]# 
Comment 4 Richard Hughes 2008-04-14 07:26:58 EDT

*** This bug has been marked as a duplicate of 442302 ***

Note You need to log in before you can comment on or make changes to this bug.