Bug 442157 - 'su' takes 10 to 40 seconds to respond
Summary: 'su' takes 10 to 40 seconds to respond
Status: CLOSED DUPLICATE of bug 442061
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F9Blocker
TreeView+ depends on / blocked
 
Reported: 2008-04-12 06:26 UTC by George Billios
Modified: 2015-01-14 23:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-12 21:26:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description George Billios 2008-04-12 06:26:18 UTC
Description of problem:
After the last update of coreutils, 'su -' takes about 10 seconds to give root
prompt after password entry. This happens trying to 'su' as another user also. 

Version-Release number of selected component (if applicable):
coreutils-6.10-18.fc9.i386

How reproducible:
Always

Steps to Reproduce:
1.Login as normal user
2.do 'su -' and enter password
3.
  
Actual results:
It takes about 10 seconds before you get the root prompt 

Expected results:
To get the prompt almost instantly as before the update.

Additional info:

Comment 1 Joonas Sarajärvi 2008-04-12 11:49:18 UTC
I just upgraded my Thinkpad T41 from Fedora 8 to Fedora 9 with Yum. I, too, am
experiencig this. It didn't happen in Fedora 8.

Strangely enough, this only happens when I try to su - inside an X session. If I
switch to a virtual terminal, su is as instantaneous as usual.

Comment 2 John Poelstra 2008-04-12 16:56:06 UTC
I'm seeing the same thing on latest rawhide 2008-04-11 on x86_64... my timing
was 40 seconds from the time I entered password and hit enter to actual root prompt.

FWIW, this was a yum upgraded system starting with F9 Beta-LIVE x86_64 as the
base install. 

Comment 3 Michal Schmidt 2008-04-12 20:45:39 UTC
Commenting out this line in /etc/pam.d/su makes it fast:
session         optional        pam_xauth.so


Comment 4 Michal Schmidt 2008-04-12 21:09:07 UTC
Even running simply the command 'xauth' takes a long time and an error message
is reported:

[michich@leela ~]$ xauth
xauth:  timeout in locking authority file
/var/run/gdm/auth-cookie-XXWCC29T-for-michich

This message reminded me of a recent changelog entry I saw in gdm:
* Wed Apr 09 2008 Ray Strode <rstrode@redhat.com> - 1:2.21.10-0.2008.04.08.1
- Install X auth cookies in /var/run/gdm instead of /tmp

So I installed an older version of gdm from before this change
(gdm-2.21.10-0.2008.04.07.3.fc9) and both xauth and gdm now work fine. Here's
the test with xauth:

[michich@leela ~]$ xauth
Using authority file /tmp/.gdm-xauth-michich.OWJM9T
xauth>


Reassigning to gdm.

Comment 5 Michal Schmidt 2008-04-12 21:26:23 UTC

*** This bug has been marked as a duplicate of 442061 ***


Note You need to log in before you can comment on or make changes to this bug.