Bug 442159 - No GLXFBConfig for default depth
No GLXFBConfig for default depth
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 03:17 EDT by Axel Thimm
Modified: 2008-04-18 00:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 00:34:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Thimm 2008-04-12 03:17:05 EDT
Description of problem:
Latest rawhide updates killed compiz on an Intel GM965. Since many xorg-x11 bits
changed I cannot say whether this was the driver or some server component.

I resetted everything and tried to reenable desktop-effects:

$ gconftool-2 --recursive-unset /apps/beryl
$ gconftool-2 --recursive-unset /schemas/apps/beryl
$ gconftool-2 --recursive-unset /apps/compiz
$ gconftool-2 --recursive-unset /schemas/apps/compiz
$ gconftool-2 --unset /apps/gnome-compiz-preferences
$ desktop-effects
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0



Version-Release number of selected component (if applicable):
(listing only the relevant packages that were updated)
xorg-x11-server-Xorg-1.4.99.901-21.20080407.fc9
xorg-x11-server-common-1.4.99.901-21.20080407.fc9
xorg-x11-drv-i810-2.2.1-20.fc9
kernel-2.6.25-0.218.rc8.git7.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.See above
2.
3.
  
Actual results:
See above

Expected results:
working compiz

Additional info:
For a couple of days now I have been running w/o any xorg.conf due to testing
bug #441589. AIGLX and compiz were working.

Now neither a xonf.org free setup, nor my previous system-config-display created
xorg.conf make a difference. There is also not any clue in the Xorg.0.log why
this isn't working. Here is a diff to the previously "working" log:

--- Xorg.0.log.compizworksbutcrashes       2008-04-10 21:40:34.000000000 +0300
+++ Xorg.0.log.nocompizatall  2008-04-12 07:54:00.000000000 +0300
@@ -4,6 +4,6 @@
 X Protocol Version 11, Revision 0
-Build Operating System: Linux 2.6.18-53.1.14.el5 x86_64 
-Current Operating System: Linux victor 2.6.25-0.204.rc8.git4.fc9.x86_64 #1 SMP
Mon Apr 7 10:25:52 EDT 2008 x86_64
-Build Date: 07 April 2008  12:15:46PM
-Build ID: xorg-x11-server 1.4.99.901-18.20080401.fc9 
+Build Operating System: Linux 2.6.18-53.1.14.el5xen x86_64 
+Current Operating System: Linux victor 2.6.25-0.218.rc8.git7.fc9.x86_64 #1 SMP
Wed Apr 9 19:55:19 EDT 2008 x86_64
+Build Date: 10 April 2008  10:19:05AM
+Build ID: xorg-x11-server 1.4.99.901-21.20080407.fc9 
        Before reporting problems, check http://wiki.x.org
@@ -14,5 +14,5 @@
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
-(==) Log file: "/var/log/Xorg.0.log", Time: Thu Apr 10 21:08:50 2008
+(==) Log file: "/var/log/Xorg.0.log", Time: Sat Apr 12 07:47:07 2008
 (EE) Unable to locate/open config file
-(II) Loader magic: 0x7b24e0
+(II) Loader magic: 0x7b2520
 (II) Module ABI versions:
@@ -107,2 +107,3 @@
        ABI class: X.Org Server Extension, version 1.0
+(II) Loading extension SELinux
 (II) Loading extension SHAPE
@@ -427,3 +428,3 @@
 (II) intel(0): Success.
-(II) intel(0): [drm] Registers = 0x2fff8000
+(II) intel(0): [drm] Registers = 0xfeb00000
 (II) intel(0): [drm] ring buffer = 0xd0000000
@@ -525,4 +526,4 @@
 (**) <default keyboard>: XkbModel: "pc105"
-(**) Option "XkbLayout" "us+inet"
-(**) <default keyboard>: XkbLayout: "us+inet"
+(**) Option "XkbLayout" "us"
+(**) <default keyboard>: XkbLayout: "us"
 (**) Option "CustomKeycodes" "off"
@@ -580,6 +581,1 @@
 (II) intel(0): EDID vendor "SEC", prod id 13889
-(II) intel(0): EDID vendor "SEC", prod id 13889
-(II) intel(0): Printing DDC gathered Modelines:
-(II) intel(0): Modeline "1280x800"x0.0   68.94  1280 1296 1344 1408  800 801
804 816 -hsync -vsync (49.0 kHz)
-(II) intel(0): EDID vendor "SEC", prod id 13889
-(II) XAA: Evicting pixmaps
Comment 1 Matěj Cepl 2008-04-14 18:45:11 EDT
This is good, but I think we still could use full /var/log/Xorg.0.log attached
to this bug as an uncompressed attachment.
Comment 2 Shawn Starr 2008-04-16 19:55:17 EDT
If this is the same issue I've seen. A newer mesa package (not in rawhide yet)
fixes this issue. I have a radeon 9600 M10 rv350 and desktop-effects/composite
work fine again.

Comment 3 Shawn Starr 2008-04-16 19:56:07 EDT
I the Mesa update would be for all drivers

Note You need to log in before you can comment on or make changes to this bug.