Bug 442163 - F9 Beta Installer does not find PATA DVD from which it was launched
F9 Beta Installer does not find PATA DVD from which it was launched
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9KernelBlocker
  Show dependency treegraph
 
Reported: 2008-04-12 05:06 EDT by Kris Arndt
Modified: 2008-04-23 21:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-23 21:18:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kernel Bug at mm/rmap.c 664 (420.51 KB, image/jpeg)
2008-04-12 05:14 EDT, Kris Arndt
no flags Details
dmesg dump of udevd general protection problems (15.16 KB, text/plain)
2008-04-18 23:03 EDT, Kris Arndt
no flags Details
Here is what happens in F9 Preview... (279.42 KB, image/jpeg)
2008-04-19 01:37 EDT, Kris Arndt
no flags Details

  None (edit)
Description Kris Arndt 2008-04-12 05:06:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9

Description of problem:
Fedora 9 Beta, Fedora 8, Fedora 8 respin (Mar 31/08) do not recognize the DVD drive that was used to launch the install process.  It asks:
"What type of media contains the packages to be installed?"
When I pick "Local CD/DVD" it says "Disc Not Found".  



Version-Release number of selected component (if applicable):
anaconda 11.4.0.55

How reproducible:
Always


Steps to Reproduce:
1. Boot with Fedora 9 Beta
2. Install or upgrade system
3. English, us keyboard layout
4. Stops at "Installation Method"
5. Select "Local CD/DVD"


Actual Results:
Disc Not Found

Expected Results:
Should have recognized CD/DVD.

Additional info:
Alt-F3 says:
"trying to mount CD device /dev/sr0 on /mnt/source"

Alt-F4 says:
<6>udevd[1431] general protection ip:b80c056e sp:bffd25b0 error:c380<6>udevd[1432] general protection ip:b80c056e sp:bffd25b0 error:c380 in udevd[b80bc000+19000]
<4> in udevd[b80bc000+19000]
<6>udevd[1433] general protection ip:b80c056e sp:bffd3640 error:c380 in udevd[b80bc000+19000]
<6>udevd[1435] general protection ip:b80c056e sp:bffd3640 error:c380 in udevd[b80bc000+19000]

System - Intel Core2Quad Q6600        
Core2Quad Q6600/ 2G DDR2/ 500GB SATA HDD/ PATA IDE DVD-/+RW/ 8500 GT Geforce 512MB video

---------

Also of note, I setup an NFS share to install over the network.  It gets past this and goes to the GUI installer, but then does not find my hard drive(s).  I've tried putting in a SATA drive and an IDE drive even though the bios sees them at boot. 

I have a JMicron JMB363 PATA and SATA controller.  I tried IDE, AHCI, RAID to no avail.  I also tried these kernel options, in various combinations:
all-generic-ide irqpoll pci=nommconf acpi=off libata.dma=0 ide=nodma noacpi noapic nolapic

On a side note, I sometimes get a kernel bug even before it asks for the language.  See attached screenshots.
Comment 1 Kris Arndt 2008-04-12 05:14:02 EDT
Created attachment 302201 [details]
Kernel Bug at mm/rmap.c 664
Comment 2 Harald Hoyer 2008-04-14 05:24:43 EDT
kernel bug assigned to udev??
Comment 3 Kris Arndt 2008-04-18 23:03:29 EDT
Created attachment 302965 [details]
dmesg dump of udevd general protection problems

This happens for a normal boot to rescue mode.
Thought I would add a text attachment for easier searching.  This does not
include the kernel bug like the screenshots include.
Comment 4 Kris Arndt 2008-04-19 01:37:36 EDT
Created attachment 302968 [details]
Here is what happens in F9 Preview...
Comment 5 Chuck Ebbert 2008-04-21 13:27:33 EDT
This looks like some kind of hardware problem: random errors all over the place.
Comment 6 Chuck Ebbert 2008-04-22 13:17:12 EDT
Has this system been stable when running an earlier release?
Comment 7 Kris Arndt 2008-04-22 13:42:31 EDT
Unfortunately, no.  It is a brand new system put together by a local shop.  They
have been good in the past, but I fear you are correct as I tried Ubuntu,
Kubuntu and others and they all exhibit the same erratic behaviour when trying
to install the OS.  I'm going to try installing Vista.  I'll report back on
success or failure.

Thanks.
Comment 8 Chuck Ebbert 2008-04-23 21:18:12 EDT
Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.