Bug 442164 - ffmpeg plugin fails to create thumbnails [NEEDINFO]
ffmpeg plugin fails to create thumbnails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 05:07 EDT by David Woodhouse
Modified: 2009-01-09 01:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 01:22:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
limburgher: needinfo? (dwmw2)


Attachments (Terms of Use)
debug output (14.03 KB, text/html)
2008-04-12 05:07 EDT, David Woodhouse
no flags Details

  None (edit)
Description David Woodhouse 2008-04-12 05:07:04 EDT
See the last item at 
http://gallery.infradead.org/main.php?g2_itemId=3206&g2_page=8 (the others were
uploaded before installing gallery2-ffmpeg)

It has a broken image for a thumbnail.

I click on it and 'edit movie' and use the thumbnail tab (from the thumbpage
plugin). I can change the time offset and it doesn't seem to fix anything.

ffmpeg is installed, and if invoked manually (ffmpeg -i cimg1069.avi -ss 0 -f
mjpeg -t 0.001 -y foo.tmp) generates a sane-looking JPEG.
Comment 1 David Woodhouse 2008-04-12 05:07:04 EDT
Created attachment 302200 [details]
debug output
Comment 2 David Woodhouse 2008-04-12 05:09:36 EDT
You'll see this in the debug output:

Must supply at least one output file
Status: 1 (expected 0)


That's expected, and the code looks like it should handle it appropriately.

Comment 3 John Berninger 2008-04-12 10:38:17 EDT
First, the simple stuff:  does this apply?  (from Gallery2 Codex)  "If you have
the Thumbnail Manager plugin installed, then check "Site admin" -> "Thumbnails"
and ensure that you remove the default thumbnail for the video mimetypes.
Failure to do this will cause the FFmpeg module to never be called to generate a
thunbnail."

I don't have any movies to test this with, can you provide a short clip that I
can retrieve somehow to upload to a test server?
Comment 4 David Woodhouse 2008-04-12 11:00:32 EDT
That seems to fix it for new movies; thanks. I removed and re-added
cimg1069.avi, and now I can even use the thumbpage module to change the time
from which the snapshot is taken.

I can't seem to fix the thumbnail for existing movies though -- I go through the
same steps (except removing and re-adding them, of course), and I still get the
broken image. Is there a way to remove the thumbnail completely and make it
start again, without reuploading the movies?

A sample movie is at http://bombadil.infradead.org/~dwmw2/cimg1055.avi -- and
there's a bunch more in the gallery I referred to above.
Comment 5 David Woodhouse 2008-04-12 11:19:41 EDT
I've reuploaded those movies, since I have them to hand. But I have others which
aren't so easy to reupload -- such as at
http://gallery.infradead.org/main.php?g2_itemId=20&g2_page=14

I note the movie size isn't set correctly on the older movies, but setting it
manually doesn't seem to help. Is there a way to remove all the auto-generated
metadata (including the old thumbnail) associated with these movies?

Comment 6 John Berninger 2008-04-12 11:35:29 EDT
There is an option under "Maintenance" in the admin panel to regenerate
thumbnails - log in as a site admin, go to "Site Admin", then "Maintenance", and
run the "Build all thumbnails/resizes" task.  This should rebuild all thumbnails
- other metadata can be cleared through the other tasks in the Maintenance panel.
Comment 7 David Woodhouse 2008-04-12 12:26:31 EDT
I tried the 'Build all thumbnails/resizes' maintenance task, and got the
following debug output (and lots more, but this was the interesting bit):

realpath(/usr/share/gallery2/modules/core/classes/../../../)
realpath(/usr/share/gallery2/)

Error (ERROR_UNSUPPORTED_OPERATION) : thumbnail video/x-msvideo in
modules/core/classes/GalleryDerivative.class at line 427
(GalleryCoreApi::error) 
in modules/core/classes/GalleryDerivative.class at line 275
(GalleryDerivative::_rebuildCache) 
in modules/core/classes/GalleryDerivativeImage.class at line
153 (GalleryDerivative::rebuildCache) 
in
modules/core/classes/helpers/GalleryDerivativeHelper_advanced.class at
line 839 (GalleryDerivativeImage::rebuildCache) 
in modules/core/classes/GalleryCoreApi.class at line 914
(GalleryDerivativeHelper_advanced::rebuildCache) 
in
modules/core/classes/helpers/GalleryDerivativeHelper_simple.class at
line 49 (GalleryCoreApi::rebuildDerivativeCache) 
in modules/core/classes/GalleryCoreApi.class at line 901
(GalleryDerivativeHelper_simple::rebuildCacheIfNotCurrent) 
in modules/core/classes/BuildDerivativesTask.class at line
99 (GalleryCoreApi::rebuildDerivativeCacheIfNotCurrent) 
in modules/core/AdminMaintenance.inc at line 90
(BuildDerivativesTask::run) 
in ??? at line 0 (AdminMaintenanceController::runTask) 
in modules/core/classes/GalleryTemplateAdapter.class at line
915
in
/srv/gallery2/g2data_5yvrt3w4/smarty/templates_c/%%626616196/%%3A^3A8^3A818B59%%theme.tpl.php
at line 69 (GalleryTemplateAdapter::trailer) 
in lib/smarty/Smarty.class.php at line 1258
in modules/core/classes/GallerySmarty.class at line 61
(Smarty::fetch) 
in modules/core/classes/GalleryTemplate.class at line 209
(GallerySmarty::fetch) 
in main.php at line 480 (GalleryTemplate::display) 
in main.php at line 94
in main.php at line 83


copy(/usr/share/gallery2/modules/core/classes/../data/broken-image.gif,
/srv/gallery2/g2data_5yvrt3w4/cache/derivative/4/0/402.dat)
getParameter permissions.file for core plugin
getParameter permissions.directory for core plugin
file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/module/_all/0/0/GalleryMimeTypeHelper_mimeData.inc)
file_exists(/srv/gallery2/g2data_5yvrt3w4/cache/derivative/4/0/402.dat)
filesize(/srv/gallery2/g2data_5yvrt3w4/cache/derivative/4/0/402.dat)
Loading plugin thumbnail
Class not defined, trying to include it.
file_exists(/usr/share/gallery2/modules/thumbnail/module.inc)
thumbnail plugin successfully instantiated
Loading plugin thumbpage
Class not defined, trying to include it.
file_exists(/usr/share/gallery2/modules/thumbpage/module.inc)
thumbpage plugin successfully instantiated
Loading plugin core
core plugin successfully instantiated
Comment 9 Bug Zapper 2008-11-26 05:28:43 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Jon Ciesla 2008-12-18 13:36:17 EST
Can you confirm whether this is still broken on the new version (2.3), and possibly on a more current release?
Comment 11 Bug Zapper 2009-01-09 01:22:39 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.