Bug 442168 - root - cannot open display
root - cannot open display
Status: CLOSED DUPLICATE of bug 442061
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 06:36 EDT by Flóki Pálsson
Modified: 2008-04-14 08:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 05:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2008-04-12 06:36:16 EDT
Description of problem:
root can not open gedit

Version-Release number of selected component (if applicable):
coreutils-6.10-18.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1.
[root@localhost ~]# gedit /var/log/dmesg
No protocol specified
cannot open display: 
Run 'gedit --help' to see a full list of available command line options.
[root@localhost ~]#
2.
3.
  
Actual results:
gedit does not open file

Expected results:
gedit opens file 

Additional info:
It works for normal user.
It is not only problem with gedit.    Nautilus has same problem 

[floki@localhost ~]$ gedit /var/log/dmesg
[floki@localhost ~]$
Comment 1 Flóki Pálsson 2008-04-13 13:50:54 EDT
Now after clean install fc9 and update all
then this works
Comment 2 Flóki Pálsson 2008-04-13 14:02:06 EDT
After rebooting then the problem is still there. 
Comment 3 Ondrej Vasik 2008-04-14 04:53:33 EDT
Could you please specify why you reported that issue against coreutils? I don't
see any connections between that bugzilla and coreutils.
From the error messages I guess you don't have DISPLAY envvar set for root.
Anyway, this has nothing to do with coreutils. And most likely is only issue
with some config file. 
Comment 4 Ondrej Vasik 2008-04-14 05:03:24 EDT

*** This bug has been marked as a duplicate of 442061 ***
Comment 5 Flóki Pálsson 2008-04-14 08:31:36 EDT
It was not sure.  It was me best gess
"Component: In which component does the bug exist?
Bugzilla requires that you select a component to enter a bug. (Not sure which to
choose? Click on the Component link. You'll see a description of each component,
to help you make the best choice.)"

Note You need to log in before you can comment on or make changes to this bug.