Bug 442196 - gdm rejects any X11 TCP requests despite 'DisallowTCP=false' in custom.conf
Summary: gdm rejects any X11 TCP requests despite 'DisallowTCP=false' in custom.conf
Status: CLOSED DUPLICATE of bug 243551
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-12 17:13 UTC by Philippe Leclercq
Modified: 2015-01-14 23:20 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-04-12 23:56:24 UTC


Attachments (Terms of Use)
libpcap trace of failing X11/TCP transaction (208 bytes, application/octet-stream)
2008-04-12 17:13 UTC, Philippe Leclercq
no flags Details
gdm custom.conf file under /etc/gdm (3.90 KB, text/plain)
2008-04-12 17:15 UTC, Philippe Leclercq
no flags Details

Description Philippe Leclercq 2008-04-12 17:13:29 UTC
gdm rejects any X11 TCP requests despite 'DisallowTCP=false' in custom.conf

Description of problem:
gdm Window Manager ignores the 'xhost +' cmd and rejects any incoming X11/TCP
requets despite the 'DisallowTCP=false' added to the custom.conf file.

Version-Release number of selected component (if applicable):
Fedora 8

Steps to reproduce :
prerequisite :
---> custom.conf must override unmodified 'default.conf' file, allowing TCP
access for X11 requests ( see file hereby attached )

1. on the Fedora 8 X/gdm server, issue the 'xhost +' command in a terminal window
[philec@philec-linux ~]$ xhost +
access control disabled, clients can connect from any host

2. rlogin or telnet to any other Linux, Solaris, HP-UX, AIX
3. initialize and export the $DISPLAY variable
[philec@philec-pro ~]$ export DISPLAY=philec-linux:0.0 
4. launch the 'xterm' command on the remote system
[philec@philec-pro ~]$ xterm
xterm Xt error: Can't open display: philec-linux:0.0


Expected results:
xterm window starts on the 'local' X/gdm server

Additional info: 
When sniffing the X11/TCP transaction, the Fedora 8 clearly returns a 'host
administratively prohibited' ICMP packet ( see trace attached )

Comment 1 Philippe Leclercq 2008-04-12 17:13:29 UTC
Created attachment 302234 [details]
libpcap trace of failing X11/TCP transaction

Comment 2 Philippe Leclercq 2008-04-12 17:15:26 UTC
Created attachment 302235 [details]
gdm custom.conf file under /etc/gdm

main default.conf file in /usr/share/gdm remains unmodifed

Comment 3 Philippe Leclercq 2008-04-12 23:56:24 UTC

*** This bug has been marked as a duplicate of 243551 ***


Note You need to log in before you can comment on or make changes to this bug.