Bug 442220 - Atheros AR5007 misrecognized, not configured: 802.11 wireless on Compaq A916NR
Atheros AR5007 misrecognized, not configured: 802.11 wireless on Compaq A916NR
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-12 19:02 EDT by P V
Modified: 2008-04-18 00:44 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 17:31:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P V 2008-04-12 19:02:51 EDT
Description of problem:

The Atheros AR5007 wireless adapter is

(1) misrecognized by    lspci|grep Atheros
01:00.0 Ethernet controller: Atheros Communications, Inc. AR5006EG 802.11 b/g
Wireless PCI Express Adapter (rev 01)

(2) not configured:  ifconfig reports only eth0 and lo.



Version-Release number of selected component (if applicable):
Hardware: Compaq Presario A916NR Notebook PC
Software: 2.6.23.15-137.fc8 #1 SMP Sun Feb 10 17:48:34 EST 2008 i686 i686 i386
GNU/Linux

How reproducible:
Always. It appears there is conflicting and complicated advice online about how
to get this working.

Steps to Reproduce:
1. Reboot
2. Find no wireless working
3. 
  
Actual results:


Expected results:  adapter correctly recognized, Wireless networking functional


Additional info:  Merely getting the adapter correctly recognized would probably
be a helpful step to sorting out the problem.
Comment 1 Dan Williams 2008-04-14 10:06:57 EDT
-> kernel since it's a driver issue; PCI-E support in ath5k is still pretty new
but I thought it should have worked on at least a few machines...
Comment 2 John W. Linville 2008-04-15 17:31:26 EDT

*** This bug has been marked as a duplicate of 254192 ***
Comment 3 Joachim Frieben 2008-04-15 18:40:16 EDT
(In reply to comment #0)
> Software: 2.6.23.15-137.fc8

The latest F8 update kernel is kernel-2.6.24.4-64.fc8. Reporting ath5k
issues for significantly older versions as is your case is meaningless.
Comment 4 P V 2008-04-18 00:44:24 EDT
Dear Joachim, 
Exactly same behavior is found with the kernel 
2.6.24.4-64.fc8 #1 SMP 

so the report is not meaningless.

Note You need to log in before you can comment on or make changes to this bug.