Bug 442227 - kernel 2.6.25-0.218.rc8.git7.fc9.x86_64 oopses in radeon module
kernel 2.6.25-0.218.rc8.git7.fc9.x86_64 oopses in radeon module
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9KernelBlocker
  Show dependency treegraph
 
Reported: 2008-04-12 20:21 EDT by Michal Jaegermann
Modified: 2008-04-16 15:12 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 15:12:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
oops trace from 2.6.25-0.218.rc8 (3.22 KB, text/plain)
2008-04-12 20:21 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2008-04-12 20:21:26 EDT
Description of problem:

The following was produced in log files:

BUG: unable to handle kernel paging request at ffffc200002b1e08
IP: [<ffffffff8838291d>] :radeon:radeon_driver_lastclose+0x21/0x3b
....
Fixing recursive fault but reboot is needed

A full oops trace is attached.

After such oops a zombie X process is left in a D state  and
cannot be killed.  A display and a keyboard stop responding although
a login from a remote is still possible.  The message "reboot is neeeded"
above is not kidding.

It looks like that this is always repeatable with a help of
'pkill -f gdm' command.  Rebooting with 2.6.25-0.204.rc8.git4.fc9.x86_64
kernel makes that command to perform without oopsing.

'pkill -f X' does not seem to be a problem.

Version-Release number of selected component (if applicable):
kernel-2.6.25-0.218.rc8.git7.fc9.  Also /usr/sbin/gdm-restart
seems to be harmless but that just sends SIGHUP to an existing
gdm process and does not terminate an exisiting one.

How reproducible:
apparently always as described
Comment 1 Michal Jaegermann 2008-04-12 20:21:26 EDT
Created attachment 302246 [details]
oops trace from 2.6.25-0.218.rc8
Comment 2 Michal Jaegermann 2008-04-14 16:30:00 EDT
I am afraid that I am getting the same oops by just logging out
from a desktop session.
Comment 3 Michal Jaegermann 2008-04-16 15:12:34 EDT
With an update to kernel-2.6.25-0.234.rc9.git1.fc9.x86_64 so far,
so good. :-)  Thanks.

Note You need to log in before you can comment on or make changes to this bug.