Bug 442289 - UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-13 19:08 EDT by John Reiser
Modified: 2008-04-15 09:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 09:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2008-04-13 19:08:56 EDT
Description of problem: pungi compose fails at step 'Making repodata' with
message: UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position
1150: ordinal not in range(128)


Version-Release number of selected component (if applicable):
pungi-1.2.14-1.fc9.noarch


How reproducible:
always

Steps to Reproduce:
1.pungi -c /usr/share/pungi/rawhide-fedora.ks --destdir=/data/Fedora9 --name
Fedora --ver 9 --discs 6
2.
3.
  
Actual results:
Pungi.Gather:INFO: Finished downloading packages.
Pungi.Pungi:INFO: Making repodata
Previous repo file missing: 
37/2157 - Packages/hunspell-bn-20050726-2.fc9.noarch.rpmTraceback (most recent
call last):
  File "/usr/bin/pungi", line 189, in <module>
    main()
  File "/usr/bin/pungi", line 94, in main
    mypungi.doCreaterepo()
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 137, in
doCreaterepo
    self._makeMetadata(self.topdir, self.config.get('default', 'cachedir'),
compsfile, repoview=True, repoviewtitle=repoviewtitle)
  File "/usr/lib/python2.5/site-packages/pypungi/pungi.py", line 96, in
_makeMetadata
    repomatic.doPkgMetadata()
  File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line 308, in
doPkgMetadata
    self.writeMetadataDocs(packages)
  File "/usr/lib/python2.5/site-packages/createrepo/__init__.py", line 414, in
writeMetadataDocs
    self.otherfile.write(po.do_other_xml_dump())
  File "/usr/lib/python2.5/site-packages/createrepo/yumbased.py", line 401, in
do_other_xml_dump
    msg += self._dump_changelog()
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1150:
ordinal not in range(128)


Expected results:
sucessful compose

Additional info:  What file has the bad character?
Comment 1 Jesse Keating 2008-04-13 22:05:43 EDT
This is actually a bug in yum.  I don't think there is a bug filed on this yet,
so I'll toss it in their queue.
Comment 2 Sergey Kurtsev 2008-04-15 08:03:16 EDT
This is not as low priority as it seems. 

Case 1.
After booting from Rawhide Live CD (build 04/04/08):
1. Select Russian language at login screen
2. Try running liveinst from command line.
It failes due to the same reason.

Case 2.
Latest updates downloaded. (15 apr 08) Trying to install Adobe Flash player:
1. Set "Russian language" in system settings.
3. Go to
http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&P2_Platform=Linux
3. Select version to download: YUM for Linux
4. After installing repo rpm: "yum search adobe" fails for the same reason.
Details here:

[root@toshiba rc.d]# yum search adobe
Loaded plugins: fedorakmod, refresh-packagekit
livna                                                    | 2.1 kB     00:00    
adobe-linux-i386                                         |  951 B     00:00    
rawhide                                                  | 2.4 kB     00:00    
tigro                                                    | 1.1 kB     00:00    
primary.xml.gz                                           | 4.2 kB     00:00    
tigro     : ################################################## 11/11
================================ Matched: adobe ================================
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.user_main(sys.argv[1:], exit_code=True)
  File "/usr/share/yum-cli/yummain.py", line 236, in user_main
    errcode = main(args)
  File "/usr/share/yum-cli/yummain.py", line 111, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 309, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 501, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 697, in search
    self.matchcallback(po, matched_value, args)
  File "/usr/share/yum-cli/output.py", line 457, in matchcallback
    msg = self.fmtKeyValFill(msg, po.summary)
  File "/usr/share/yum-cli/output.py", line 256, in fmtKeyValFill
    val = str(val)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 22-30:
ordinal not in range(128)

The bug itself probably comes from Python issue: http://bugs.python.org/issue2517

I'd ask you to change issue severity to high since inconsistent unicode support
by yum makes it impossible for user with non-english interface to do some
updates and run install from Live CD.
Comment 3 Seth Vidal 2008-04-15 08:07:42 EDT
are you're still getting this after installing:
http://koji.fedoraproject.org/packages/yum/3.2.14/7.fc9/noarch/yum-3.2.14-7.fc9.noarch.rpm

Comment 4 Sergey Kurtsev 2008-04-15 08:48:51 EDT
As I figured out - in "Case 2" it previously failed  with (tm) and (r) unicode
characters in package descriptions. 
I don't know in which way it may relate to Russian language interface but it
work's fine with "yum search" now. Thanks. 

No opportunity to check with liveinst though.

Note You need to log in before you can comment on or make changes to this bug.