This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442310 - pki-ca tomcat server does not start
pki-ca tomcat server does not start
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: Tomcat (Show other bugs)
1.0
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Harmsen
Chandrasekar Kannan
:
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2008-04-14 04:33 EDT by Kapetanakis Giannis
Modified: 2015-01-04 18:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
catalina.out errors (3.02 KB, text/plain)
2008-04-14 04:33 EDT, Kapetanakis Giannis
no flags Details

  None (edit)
Description Kapetanakis Giannis 2008-04-14 04:33:47 EDT
Description of problem:

The pki-ca tomcat does not start:

short error summary:
java.lang.reflect.InvocationTargetException
Caused by: java.lang.ClassFormatError:
org.apache.tomcat.util.net.jss.JSSImplementation (unrecognized class file version)

Version-Release number of selected component (if applicable):
Linux is fedora 8 up2date,
pki-ca-1.0.0-1.fc8 installed with
yum install pki-ca from http://pki.fedoraproject.org/pki/download/pki/1.0.0/pki.repo

Problem Details:
Server does not start and I get errors in /var/log/pki-ca/catalina.out
I've attached the file.

I've also tried with jdk 1.5 from SUN and setting JAVA_HOME
where applicable but I get the same errors.

Nevertheless even if the server does not start,
the script does echo:

PKI service(s) are available at https://fedora2.example.com:9443

netstat -an does not show any open (relevant) port 
ps does not show any running (relevant) process 

Regards,
Kapetanakis Giannis
Comment 1 Kapetanakis Giannis 2008-04-14 04:33:48 EDT
Created attachment 302313 [details]
catalina.out errors
Comment 2 Kapetanakis Giannis 2008-04-14 06:53:24 EDT
After installing java-1.7.0-icedtea
problem was solved.
http://pki.fedoraproject.org/wiki/PKI_Runtime_Environments

After that I had a minor problem with my LC_CTYPE which was set to el_GR.
java.util.MissingResourceException: Can't find bundle for base name LogMessages,
locale el_GR

I changed to en_US before starting and everything worked.

Giannis

Comment 3 Christina Fu 2008-04-22 12:46:50 EDT
Matt, could you please see if anything is adaptable to the Dogtag wiki?  Thanks.
Comment 4 Matthew Harmsen 2008-04-23 13:07:45 EDT
Added this as a new "Internationalization" issue to the following page:

http://pki.fedoraproject.org/wiki/PKI_Known_Issues
Comment 5 Chandrasekar Kannan 2008-08-26 20:28:52 EDT
Bug already MODIFIED. setting target CS8.0 and marking screened+
Comment 6 Jenny Galipeau 2009-06-11 15:28:58 EDT
verified - on wiki:

Problem: Per Bugzilla Bug #442310, I had a minor problem with my LC_CTYPE which was set to el_GR:

   java.util.MissingResourceException: Can't find bundle for base name LogMessages,locale el_GR

Solution: Change LC_CTYPE to en_US before starting and everything will work.
[edit]

Note You need to log in before you can comment on or make changes to this bug.