Bug 442312 - [RFE]: Matching background colour in startkde for waves
[RFE]: Matching background colour in startkde for waves
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 04:51 EDT by Sebastian Vahl
Modified: 2008-04-15 05:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 05:14:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
automatic login from KDM with old colour and waves ksplash theme (72.69 KB, image/png)
2008-04-14 04:51 EDT, Sebastian Vahl
no flags Details
automatic login from KDM with new colour and waves ksplash theme (76.93 KB, image/png)
2008-04-14 04:52 EDT, Sebastian Vahl
no flags Details
Screenshot of RHGB with waves theme for comparison (73.41 KB, image/png)
2008-04-14 05:41 EDT, Sebastian Vahl
no flags Details

  None (edit)
Description Sebastian Vahl 2008-04-14 04:51:01 EDT
Description of problem:
The standard background colour for KDM is defined in /usr/bin/startkde:

# Set the background to the Red Hat default
# The standard X background is nasty, causing moire effects and exploding
# people's heads. We use colours from the standard KDE palette for those with
# palettised displays.
if test -z "$XDM_MANAGED" || echo "$XDM_MANAGED" | grep ",auto" > /dev/null; 
then
  xsetroot -solid "#5477A0"
fi


This colour is only shown if no theme is used and also no wallpaper is set. 
But it is also shown if KDM is configured to use an automatic login. This is 
the case on the live images.

I've picked the background colour of rhgb with kcolorchooser from a vmware 
installation and used it in startkde. A matching background colour for rhgb 
and KDM is looking much nicer, IMHO.

The colour is: #103D77

The two screenshots are taken from a vmware installation. The first one with 
ksplash and the old colour, the second one with the new colour.
Comment 1 Sebastian Vahl 2008-04-14 04:51:01 EDT
Created attachment 302314 [details]
automatic login from KDM with old colour and waves ksplash theme
Comment 2 Sebastian Vahl 2008-04-14 04:52:06 EDT
Created attachment 302315 [details]
automatic login from KDM with new colour and waves ksplash theme
Comment 3 Sebastian Vahl 2008-04-14 05:41:06 EDT
Created attachment 302321 [details]
Screenshot of RHGB with waves theme for comparison
Comment 4 Kevin Kofler 2008-04-14 10:46:11 EDT
Sebastian, you have commit access to kdebase-workspace, why don't you just edit 
it? ;-) That color is set in the redhat-startkde patch, so we don't even have 
to add a new patch, just edit the existing one.
Comment 5 Sebastian Vahl 2008-04-14 10:56:11 EDT
(In reply to comment #4)
> Sebastian, you have commit access to kdebase-workspace, why don't you just edit 
> it? ;-) That color is set in the redhat-startkde patch, so we don't even have 
> to add a new patch, just edit the existing one.

Sure. But I don't want to do this edit without discussing it before. :)

Comment 6 Kevin Kofler 2008-04-14 11:03:52 EDT
I have no objections.

IIRC the old color was chosen because it matched the Infinity theme, it no 
longer fits now that we have Waves.
Comment 7 Sebastian Vahl 2008-04-15 05:14:52 EDT
(In reply to comment #6)
> I have no objections.

Ok. Thanks. I've updated the package and build it:

* Tue Apr 15 2008 Sebastian Vahl <fedora@deadbabylon.de> - 4.0.3-13
- update redhat-startkde.patch to match waves background colour (#442312)

But I've not requested inclusion in f9-final from rel-eng, yet. This could be 
done when some major changes happen.

Comment 8 Kevin Kofler 2008-04-15 05:24:19 EDT
It should be done ASAP, there's not much time left and the change is perfectly 
safe for f9-final.

Note You need to log in before you can comment on or make changes to this bug.