Bug 442321 - strace X server will halt it
strace X server will halt it
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 06:34 EDT by Christoph Höger
Modified: 2008-04-25 13:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 13:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of Xorg (232.24 KB, text/plain)
2008-04-15 11:08 EDT, Christoph Höger
no flags Details

  None (edit)
Description Christoph Höger 2008-04-14 06:34:29 EDT
Description of problem:
There seems to be some deadlock problem when stracing x.org XServer in a gui
terminal.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-44.fc8

How reproducible:
always

Steps to Reproduce:
1. open xterm, gnome-terminal or whatever gui terminal you use
2. become root
3. get pid of X
4. strace -p $pid
5. move mouse around
  
Actual results:
XServer hangs

Expected results:
XServer should run
Comment 1 Matěj Cepl 2008-04-14 07:10:38 EDT
Could we get please at least partial result of the strace? And also
/var/log/Xorg.0.log might be interesting as well. Please, attach these files as
separate uncompressed attachments to this bug.

Thank you.
Comment 2 Christoph Höger 2008-04-15 11:08:19 EDT
Hi,

discussion with some co-workers brought up that this may be simply a full
x-server queue. 

The problem is, that it runs well, as long as you don't generate new x-messages
(mouse move, new window etc)

Comment 3 Christoph Höger 2008-04-15 11:08:54 EDT
Created attachment 302472 [details]
strace of Xorg
Comment 4 Adam Jackson 2008-04-23 11:41:30 EDT
You're attaching strace to the X server.  You're expecting the X server to
display the results.  Which will cause more X server activity, which will make
it print more things, which...

I highly recommend not doing this.

Note You need to log in before you can comment on or make changes to this bug.