Bug 442322 - The textbox in chat/IM window is not resizable after last pidgin update
The textbox in chat/IM window is not resizable after last pidgin update
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 07:07 EDT by Steve
Modified: 2008-04-16 18:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 10:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve 2008-04-14 07:07:14 EDT
Description of problem:
The textbox of the chat/IM window is not resizable after last pidgin update.

Version-Release number of selected component (if applicable):
pidgin-2.4.1-1.fc7

How reproducible:
I am assuming 100% reproducible. I haven't done anything other than running 'yum
update'

Steps to Reproduce:
1. Use the previous version of pidgin (I am not quite sure what that was since I
regularly do a yum update). Notice that the text entry box in a conversation
window is resizable.

2. update to the latest version of pidgin

3. Notice that the text entry box in a conversation window is no longer resizable.

Actual results:
The text entry box in a conversation window is not resizable.

Expected results:
The text entry box in a conversation window should be resizable, or at least
larger than the current 2 line height. Although it does not affect
functionality, it is annoyingly ugly when you use pidgin (especially for
IRC/chat rooms) with the chat window maximized to full screen.

Additional info:
---
Comment 1 Stu Tomlinson 2008-04-14 09:49:19 EDT
This is by design. The entry area will grow if you need to enter more than 2
lines of text (up to a maximum of 50% of the window height).
Comment 2 Steve 2008-04-14 10:35:11 EDT
Hi,

Like I mentioned, it is not about functionality but aesthetics. I'd prefer a
visibly larger text area. I don't need to enter more than 2 lines of text, but
would like to see what I am typing without having to look at the very bottom of
the screen.

In any case, the inability to adjust the height is *not* by design. It is a
regression introduced in the last update, like I mentioned.

regards,
- steve
Comment 3 Stu Tomlinson 2008-04-14 10:41:04 EDT
Umm, it is by design.
Comment 4 Steve 2008-04-16 18:53:50 EDT
Ok, this is fun !

Pasting some interesting stuff here for anyone who finds the small 2 line
default text entry box in pidgin annoying and bothers to search this bugzilla.

Since I wasn't satisfied with Stu's "Umm, it is by design" comment, I decided to
file a bug with upstream pidgin in the hope that they would see things differently:

http://developer.pidgin.im/ticket/5542

it is only when I received a reply on that did I realized that this problem
annoyed someone enough to create a fork of pidgin !! Here's the history:

- Bug is filed: http://developer.pidgin.im/ticket/4962
- Bug gets closed
- Request for enhancement is filed: http://developer.pidgin.im/ticket/4986
- 264 comments follow !!
- Pidgin is forked ! http://funpidgin.sourceforge.net/
- Eventually someone posts a plugin (of sorts) to ^fix^ this in pidgin:
http://developer.pidgin.im/ticket/5296

Well, all that said, I think I'll start using funpidgin. (need to con somebody
into either adding the plugin to purple-plugin_pack-pidgin or to create a
funpidgin fedora package.)

- steve

Note You need to log in before you can comment on or make changes to this bug.