Bug 442328 - Remote database should be more easily findable
Summary: Remote database should be more easily findable
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lirc   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
: 451441 (view as bug list)
Depends On:
Blocks: 442329
TreeView+ depends on / blocked
 
Reported: 2008-04-14 12:43 UTC by Bastien Nocera
Modified: 2008-06-30 10:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-30 10:31:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lirc-separate-remotes.patch (1.49 KB, patch)
2008-05-12 14:09 UTC, Bastien Nocera
no flags Details | Diff

Description Bastien Nocera 2008-04-14 12:43:55 UTC
Currently, the remotes database lives in
/usr/share/doc/lirc-doc-%{lirc_version}/remotes

gnome-lirc-properties would need to hardcode the version number in the spec file
to be able to find it. It would be better if the remotes database was:
- in the main package
- in an unchanging location (/usr/share/lirc/remotes would be a good one)

Comment 1 Ville Skyttä 2008-04-14 18:00:46 UTC
Once upon a time, my lirc package included in addition to the remote configs
shipped in lirc tarballs everything from http://www.lirc.org/remotes/ which adds
quite a bit to the package payload which is not very welcome in trimmed down
setups.  That data is usually only needed in the configuration phase and not in
"production runtime".  Shipping them somewhere else than the main package is a
relic of that.

Now, if only the remote configs in the main lirc package are shipped, we're
talking only about 750kB of installed data which isn't a huge deal in just about
any setup, but I'd rather keep them in a separate package nevertheless.

So I'd be fine with let's say a lirc-remotes subpackage, using
/usr/share/lirc/remotes.  Or perhaps even a completely separate source rpm from
which the remotes package is built from, that way it'd be independent of main
lirc package updates, could be noarch, and if someone wants to bundle everything
from http://www.lirc.org/remotes/ in it again, it wouldn't bloat even the lirc
source package.

Thoughts?

Comment 2 Bastien Nocera 2008-04-14 22:27:10 UTC
An lirc-remotes package with a better path would be just great for me. I don't
think that a separate source rpm would be warranted, unless we wanted to pull a
lot more data from upstream.

Comment 3 Bastien Nocera 2008-05-12 14:09:09 UTC
Created attachment 305132 [details]
lirc-separate-remotes.patch

Patch to separate the remotes definitions (might not apply cleanly, as I've
already modified the .spec for the patches in bug 442248).

Comment 4 Jarod Wilson 2008-06-02 18:59:19 UTC
For the time being, yeah, I think just a separate sub-package with the existing
remote defs is enough. I've gone ahead and done something similar to the patch
provided in comment #3.

Comment 5 Ville Skyttä 2008-06-15 07:07:23 UTC
*** Bug 451441 has been marked as a duplicate of this bug. ***

Comment 6 Bastien Nocera 2008-06-30 10:31:16 UTC
Works fine for me, closing.


Note You need to log in before you can comment on or make changes to this bug.