Bug 442354 - The NetworkManager applet could not find some required resources. It cannot continue.
The NetworkManager applet could not find some required resources. It cannot ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 11:04 EDT by Charles R. Anderson
Modified: 2008-04-14 12:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 12:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of NM dialog box (10.93 KB, image/png)
2008-04-14 11:05 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2008-04-14 11:04:45 EDT
Description of problem:

Got a pop up dialog saying "The NetworkManager applet could not find some
required resources.  It cannot continue.".  It didn't seem to crash, though.

Version-Release number of selected component (if applicable):
0.7.0-0.9.1.svn3549.fc9.i386

How reproducible:
didn't try

Actual results:

Here are the process that are still running:

cra       2954  0.0  0.7  61608 16044 ?        S      Apr 10 00:00:00 nm-applet
--sm-disable

root      2407  0.0  0.0   4044  1308 ?        Ss     Apr 10 00:00:00
NetworkManagerDispatcher
--pid-file=/var/run/NetworkManager/NetworkManagerDispatcher.pid
root      2428  0.0  0.0  15088  1956 ?        Ssl    Apr 10 00:00:00
NetworkManager --pid-file=/var/run/NetworkManager/NetworkManager.pid

It looks like these processes are left over from an older version of NM, since
it was updated on April 11:

Apr 11 11:29:46 Updated: 1:NetworkManager-glib-0.7.0-0.9.1.svn3549.fc9.i386
Apr 11 11:29:48 Updated: 1:NetworkManager-0.7.0-0.9.1.svn3549.fc9.i386
Apr 11 11:29:49 Updated: 1:NetworkManager-gnome-0.7.0-0.9.1.svn3549.fc9.i386
Comment 1 Charles R. Anderson 2008-04-14 11:05:41 EDT
Created attachment 302351 [details]
screenshot of NM dialog box
Comment 2 Dan Williams 2008-04-14 12:01:52 EDT
You'll need to kill and restart the applet.  This occurs because some icons got
renamed during the RPM update, but you're still running the old applet.  When
PackageKit does stuff, it triggers a panel resize, which causes the applet to
re-read it's icons (since the panel size changed the icon sizes will be
different), and since it's the old applet it can't find them...

Note You need to log in before you can comment on or make changes to this bug.