Bug 442443 - .doc files have ? (question mark) icon
.doc files have ? (question mark) icon
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On: kde42
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 16:16 EDT by Orion Poplawski
Modified: 2009-02-19 06:42 EST (History)
8 users (show)

See Also:
Fixed In Version: KDE 4.2.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-19 06:42:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 18072 None None None Never

  None (edit)
Description Orion Poplawski 2008-04-14 16:16:39 EDT
Description of problem:

The .doc files on my desktop (and a newly created test user) are using a ? icon.
 No idea how this gets set or whose fault this might be.  xls files are okay
(show some kind of spreadsheet icon).

Version-Release number of selected component (if applicable):
kdebase-4.0.3-6.fc9.i386
Comment 1 Rex Dieter 2008-04-14 17:19:32 EDT
shared-mime-info should handle mimetypes, etc, now.
Comment 2 Rex Dieter 2008-04-14 17:22:19 EDT
I take it back, you actually need an app installed that claims to be able to
handle that mimetype, that provides an icon.
Comment 3 Kevin Kofler 2008-04-14 17:25:12 EDT
So I guess KWord is only registering it with the old KDE 3 system? KOffice 
probably needs to be fixed to use shared-mime-info.
Comment 4 Rex Dieter 2008-04-14 17:28:18 EDT
ignore me, for now, I'll keep digging.  :)
Comment 5 Orion Poplawski 2008-04-14 17:29:58 EDT
Should pick of OO too:


/usr/share/applications/openoffice.org-1.9-writer.desktop:
MimeType=application/vnd.oasis.opendocument.text;application/vnd.oasis.opendocument.text-template;application/vnd.oasis.opendocument.text-web;application/vnd.oasis.opendocument.text-master;application/vnd.sun.xml.writer;application/vnd.sun.xml.writer.template;application/vnd.sun.xml.writer.global;application/vnd.stardivision.writer;application/msword;application/vnd.ms-word;application/x-doc;application/rtf;application/vnd.wordperfect;application/wordperfect
Icon=openofficeorg-writer


Icons are here:
/usr/share/icons/hicolor/16x16/apps/openofficeorg-writer.png
/usr/share/icons/hicolor/32x32/apps/openofficeorg-writer.png
/usr/share/icons/hicolor/48x48/apps/openofficeorg-writer.png
/usr/share/icons/locolor/16x16/apps/openofficeorg-writer.png
/usr/share/icons/locolor/32x32/apps/openofficeorg-writer.png
Comment 6 Orion Poplawski 2008-04-14 17:31:49 EDT
FYI - I don't have koffice.
Comment 7 Kevin Kofler 2008-04-14 17:34:03 EDT
The file type icons don't come from the application (in other words, that 
Icon=openofficeorg-writer is irrelevant). An icon matching the name of the MIME 
type is searched.
Comment 8 Orion Poplawski 2008-04-14 17:42:13 EDT
So it should be using:

/usr/share/icons/oxygen/32x32/mimetypes/application-vnd.ms-word.png

?

Maybe a naming/alias issue:

  <mime-type type="application/msword">
    <sub-class-of type="application/x-ole-storage"/>
    <glob pattern="*.doc"/>
    <alias type="application/vnd.ms-word"/>
    <alias type="application/x-msword"/>
  </mime-type>


gnome has:

/usr/share/icons/gnome/16x16/mimetypes/gnome-mime-application-msword.png
Comment 9 Rex Dieter 2008-04-14 20:01:30 EDT
I tried various things here, but couldn't get the mimetype to match/use the
icon.  Something is amiss, but I think at least it's partially some goofy and/or
duplicated parts in the application/msword.xml mimetype.
Comment 10 Bug Zapper 2008-05-14 05:26:25 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Steven M. Parrish 2008-06-23 16:31:14 EDT
Is this still an issue with KDE 4.0.5?
Comment 12 Orion Poplawski 2008-06-23 18:14:01 EDT
(In reply to comment #11)
> Is this still an issue with KDE 4.0.5?

Yes.
Comment 13 Steven M. Parrish 2008-09-28 18:15:29 EDT
Ping
Comment 14 Orion Poplawski 2008-09-29 16:23:51 EDT
I'm seeing this with KDE 4.1.2 on latest rawhide.
Comment 15 Rex Dieter 2009-01-06 09:11:01 EST
It indeed was a shared-mime-info bug, fixed yesterday upstream.
Comment 16 Bastien Nocera 2009-01-06 09:53:17 EST
(In reply to comment #15)
> It indeed was a shared-mime-info bug, fixed yesterday upstream.

Not really. The original bug is on F9, and F9 has shared-mime-info-0.30-3.fc9 which doesn't have the bug fixed yesterday.

Either reassign it to whatever KDE bit is handling the icon fetching, or mark this as an F10/rawhide bug.
Comment 17 Rex Dieter 2009-01-06 10:11:21 EST
fixed *upstream* (or so I was told by dfaure):
https://bugs.freedesktop.org/show_bug.cgi?id=18072
Comment 18 Bastien Nocera 2009-01-06 12:26:30 EST
(In reply to comment #17)
> fixed *upstream* (or so I was told by dfaure):
> https://bugs.freedesktop.org/show_bug.cgi?id=18072

I know, I'm the upstream maintainer of shared-mime-info. That doesn't answer my question though.
Comment 19 Rex Dieter 2009-01-06 12:50:57 EST
Looks like recent kde's (tested kde-4.1.85 here) workaround it, so any combination of recent kde + shared-mime-info is mmm good.

Ok, let's bounce this back to kde...
Comment 20 Steven M. Parrish 2009-01-10 09:59:58 EST
Ok its bounced back into our laps.  What do you want to do with it?
Comment 21 Rex Dieter 2009-01-10 10:04:28 EST
It's blocking on kde42 updates.   When they land, this is fixed.
Comment 22 Ngo Than 2009-01-28 10:47:12 EST
i don't see this issue anymore in F10 with 4.2.0.
Comment 23 Orion Poplawski 2009-01-28 16:28:57 EST
Indeed.  I do still still see ? for the following:

.cert
.crt
.p12
.sxi
.sxw
.xlsx

But perhaps these are general mime issues...
Comment 24 Fedora Update System 2009-02-04 21:26:34 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdeedu-4.2.0-2.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdelibs-4.2.0-7.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kde-l10n kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 25 Fedora Update System 2009-02-06 00:24:06 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-settings-4.1-5.20090126svn.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-settings kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387
Comment 26 Fedora Update System 2009-02-07 17:20:55 EST
kdeutils-4.2.0-1.fc10, kdetoys-4.2.0-1.fc10, kdesdk-4.2.0-1.fc10, kdeplasma-addons-4.2.0-1.fc10, kdepimlibs-4.2.0-1.fc10, kdepim-4.2.0-2.fc10, kdenetwork-4.2.0-2.fc10, kdemultimedia-4.2.0-1.fc10.1, kdegraphics-4.2.0-1.fc10, kdegames-4.2.0-1.fc10, kdebase-runtime-4.2.0-3.fc10, kdebase-4.2.0-2.fc10, kdebindings-4.2.0-1.fc10, kdeartwork-4.2.0-1.fc10, kdeadmin-4.2.0-1.fc10.1, kdeaccessibility-4.2.0-1.fc10, soprano-2.2.1-1.fc10, strigi-0.6.3-1.fc10, akonadi-1.1.1-1.fc10, automoc-1.0-0.11.rc3.fc10, compiz-0.7.8-7.fc10, kde-plasma-runcommand-1.0-1.fc10, kde-plasma-quickaccess-0.7.1-7.fc10, kdebluetooth-0.3-1.fc10, kde-i18n-3.5.10-2.fc10, krazy2-2.8-7.20090127svn.fc10, kde-settings-4.1-6.20090206svn.fc10, phonon-4.3.0-5.fc10, kdelibs-4.2.0-9.fc10, kdeedu-4.2.0-5.fc10, kde-l10n-4.2.0-2.fc10, kdebase-workspace-4.2.0-4.fc10.2 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdeutils kdetoys kdesdk kdeplasma-addons kdepimlibs kdepim kdenetwork kdemultimedia kdegraphics kdegames kdebase-runtime kdebase kdebindings kdeartwork kdeadmin kdeaccessibility soprano strigi akonadi automoc compiz kde-plasma-runcommand kde-plasma-quickaccess kdebluetooth kde-i18n krazy2 kde-settings phonon kdelibs kdeedu kde-l10n kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1387

Note You need to log in before you can comment on or make changes to this bug.