Bug 442444 - traceback while preupgrading a RAID0 set
traceback while preupgrading a RAID0 set
Status: CLOSED DUPLICATE of bug 441770
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-14 16:19 EDT by Will Woods
Modified: 2008-04-16 22:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 22:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacdump.txt (116.80 KB, text/plain)
2008-04-14 16:19 EDT, Will Woods
no flags Details

  None (edit)
Description Will Woods 2008-04-14 16:19:08 EDT
After running preupgrade on an F8 system with raid0 root (/dev/sda3 and
/dev/sda5), anaconda traces back when you tell it to upgrade the Fedora 8 system
on /dev/md0.

The traceback looks like this:

anaconda 11.4.0.71 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/fsset.py", line 2366, in <lambda>
    self.members.sort(cmp=lambda x,y: cmp(x.getDevice(),y.getDevice()))
  File "/usr/lib/anaconda/fsset.py", line 2366, in __init__
    self.members.sort(cmp=lambda x,y: cmp(x.getDevice(),y.getDevice()))
  File "/usr/lib/anaconda/fsset.py", line 2687, in makeDevice
    existing=1)
  File "/usr/lib/anaconda/fsset.py", line 2839, in readFstab
    device = makeDevice(fields[0][5:])
  File "/usr/lib/anaconda/upgrade.py", line 215, in mountRootPartition
    newfsset = readFstab(anaconda)
  File "/usr/lib/anaconda/upgrade.py", line 377, in upgradeMountFilesystems
    allowDirty = 0)
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1259, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'str' object has no attribute 'getDevice'

Local variables in innermost frame:
y: sda3
x: sda5

Full anacdump.txt is attached.
Comment 1 Will Woods 2008-04-14 16:19:08 EDT
Created attachment 302385 [details]
anacdump.txt
Comment 2 Jeremy Katz 2008-04-16 22:53:37 EDT
This is actually the same root cause as bug 441770

*** This bug has been marked as a duplicate of 441770 ***

Note You need to log in before you can comment on or make changes to this bug.