Bug 442448 - New Mail::IMAPClient doesn't change \n to \r\n in messages uploaded from strings
New Mail::IMAPClient doesn't change \n to \r\n in messages uploaded from strings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-Mail-IMAPClient (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 16:41 EDT by Jonathan Kamens
Modified: 2008-07-23 03:05 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.08-1.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-23 03:05:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to do LF -> CRLF in uploaded messages (380 bytes, patch)
2008-04-14 16:41 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Jonathan Kamens 2008-04-14 16:41:12 EDT
An IMAP client Perl script that I have that uses Mail::Box::Manager stopped
working when I upgrade to Mail::IMAPClient 3.05.  It appears that this is
because there's a bug in 3.05 -- it doesn't convert bare newlines to CRLF in
messages uploaded from strings (it looks like it does the right thing in
messages uploaded from files).  Patch is attached.  Serious enough bug that
might be worthwhile to take patch before upstream maintainer gets to it.
Comment 1 Jonathan Kamens 2008-04-14 16:41:12 EDT
Created attachment 302388 [details]
patch to do LF -> CRLF in uploaded messages
Comment 2 Jonathan Kamens 2008-04-14 16:44:08 EDT
Submitted upstream as http://rt.cpan.org//Ticket/Display.html?id=35031 .
Comment 3 Bug Zapper 2008-05-14 05:26:45 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2008-07-21 15:20:23 EDT
perl-Mail-IMAPClient-3.08-1.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-07-23 03:05:08 EDT
perl-Mail-IMAPClient-3.08-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.