Bug 442449 - Please add "missing" -I/usr/include/rpm option to CFLAGS
Please add "missing" -I/usr/include/rpm option to CFLAGS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-14 16:48 EDT by Robert Scheck
Modified: 2008-05-13 11:26 EDT (History)
0 users

See Also:
Fixed In Version: 6.8-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 11:26:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch which solves the problem for me (592 bytes, patch)
2008-04-14 16:51 EDT, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2008-04-14 16:48:59 EDT
Description of problem:
Please add "missing" -I/usr/include/rpm option to CFLAGS. I think this should
not hurt anything, but it makes other rpm implementations usable to rebuild gdb
against. Thank you.

Version-Release number of selected component (if applicable):
gdb-6.8-1

How reproducible:
Rebuild gdb with having rpm-devel of another rpm implementation installed; it
will fail, because -I/usr/include/rpm in CFLAGS is missing.

Expected results:
Having -I/usr/include/rpm somewhere in CFLAGS...
Comment 1 Robert Scheck 2008-04-14 16:51:07 EDT
Created attachment 302390 [details]
Patch which solves the problem for me
Comment 2 Jan Kratochvil 2008-04-14 16:58:31 EDT
Thanks, understood, to be applied for F9, the librpm integrating patch is now an
ugly hack already as it does not use the autotools magic, it should get cleaned
up later for the upstream.
Comment 3 Jan Kratochvil 2008-04-16 11:02:24 EDT
Committed to Rawhide:
* Wed Apr 16 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-3
- Fix build on non-standard rpm-devel includes (Robert Scheck, BZ 442449).
Comment 4 Fedora Update System 2008-05-12 08:23:56 EDT
gdb-6.8-5.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-05-13 11:25:56 EDT
gdb-6.8-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.