Bug 442491 - applet notifies user several times about same error
Summary: applet notifies user several times about same error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: F9Target
TreeView+ depends on / blocked
 
Reported: 2008-04-15 03:10 UTC by Bill Nottingham
Modified: 2014-03-17 03:13 UTC (History)
1 user (show)

Fixed In Version: 0.7.82.3-2.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 22:27:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2008-04-15 03:10:01 UTC
Description of problem:

The applet could check the connection status with NetworkManager - right now, if
the network goes down, it will continually pop up about the printer not being
reachable, rather than popping up once and then ignoring it until the network
was back online.

Version-Release number of selected component (if applicable):

system-config-printer-0.7.82.2-1.fc9.x86_64

Comment 1 Tim Waugh 2008-04-15 09:36:59 UTC
The key is that it ought to pop up once per error -- i.e. once per (printer,
state-reason) pair while that state-reason is set -- and no more.  I'm pretty
sure this is working correctly in 0.9.90 (post-F9 rawhide).

I've checked in a fix for 0.7.82.x upstream to use some of the same approach
used in trunk for this, so that we can get this fixed in an update.

Comment 2 Tim Waugh 2008-04-15 11:25:45 UTC
Built as system-config-printer-0.7.82.2-2.fc9.

Comment 3 Tim Waugh 2008-05-09 14:44:09 UTC
..but reverted in 0.7.82-4.fc9.  Will get this in an update.

Comment 4 Fedora Update System 2008-05-09 14:47:29 UTC
system-config-printer-0.7.82.3-1.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-05-13 15:21:45 UTC
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-printer'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3820

Comment 6 Bug Zapper 2008-05-14 09:27:34 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Tim Waugh 2008-05-16 09:45:31 UTC
Works for me.

Comment 8 Fedora Update System 2008-05-17 22:26:59 UTC
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2008-07-26 06:09:35 UTC
system-config-printer-0.7.82.3-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.