Bug 442494 - Cannot resume from suspend on a Lenovo Thinkpad T61p
Cannot resume from suspend on a Lenovo Thinkpad T61p
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 00:01 EDT by Patrick Klingemann
Modified: 2013-03-05 22:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 11:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
drivers/base/power/main.c (11.80 KB, text/plain)
2008-05-22 10:48 EDT, Patrick Klingemann
no flags Details

  None (edit)
Description Patrick Klingemann 2008-04-15 00:01:35 EDT
Description of problem: Cannot resume from suspend on a Lenovo Thinkpad T61p.


Version-Release number of selected component (if applicable):  2.22.1


How reproducible:  Every time I attempt to resume from suspend.


Steps to Reproduce:
1.  Log into gnome.
2.  Click System -> Shut Down -> Suspend
3.  Wait for laptop to suspend completely, (cpu and fans off, suspend LED lit)
4.  Press power button to restart laptop.
  
Actual results:  Screen is blank and does not seem to power up.  Cannot restart
the X Server (ctrl-alt-backspace).  Requires hard reboot.


Expected results:  The gnome locked screen should be displayed allowing the user
to unlock the screen by supplying a password.


Additional info:  Nvidia Quadro FX 570M, using Fedora supplied "nv" driver.
Comment 1 Bug Zapper 2008-05-14 05:27:54 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Matthew Garrett 2008-05-14 14:49:26 EDT
The nv driver is currently unable to reinitialise the video hardware after
suspend. I'm looking into workarounds.
Comment 3 Patrick Klingemann 2008-05-14 15:35:46 EDT
Matthew, please let me know how I can help.
Comment 4 Tom Ballard 2008-05-16 14:14:56 EDT
I'd like to volunteer to help as well.  I've got a T61p which is pretty much
unusable without the ability to suspend.  (I can live with the nv driver, but
not being able to suspend is a killer)  Since there is no other option, is it
possible to get the priority/severity of this a bit above low/low until there is
at least a workaround?

Relevant HAL info:

  system.hardware.primary_video.product = 1036  (0x40c)  (int)
  system.hardware.primary_video.vendor = 4318  (0x10de)  (int)
  system.hardware.product = '64575KU'  (string)
  system.hardware.vendor = 'LENOVO'  (string)
  system.hardware.version = 'ThinkPad T61p'  (string)

  power_management.quirk.s3_bios = true  (bool)
  power_management.quirk.vbemode_restore = true  (bool)

Reproducable on kernels:

  2.6.25-14.fc9.i686
  2.6.25.3-18.fc9.i686 

Other details:
  - I've tried a bunch of the suspend quirks, but so far nothing has worked.
  - occurs both in X and in runlevel 3.
  - occurs both on and off battery power
Comment 5 Patrick Klingemann 2008-05-22 10:48:51 EDT
Created attachment 306389 [details]
drivers/base/power/main.c
Comment 6 Patrick Klingemann 2008-05-22 10:49:21 EDT
Comment on attachment 306389 [details]
drivers/base/power/main.c

My HAL info:
  system.hardware.primary_video.product = 1036	(0x40c)  (int)
  system.hardware.primary_video.vendor = 4318  (0x10de)  (int)
  system.hardware.product = '6459CTO'  (string)
  system.hardware.vendor = 'LENOVO'  (string)
  system.hardware.version = 'ThinkPad T61p'  (string)

  power_management.quirk.none = true  (bool)

Following the HAL Sleep debug process documented here:
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-advanced.html

I got stuck at:  

cat dmesg.txt | grep "hash matches"

the result of which was:

hash matches drivers/base/power/main.c:222

I downloaded the kernel srpm (2.6.25.3-18.fc9.i686) and looked at main.c
(attached) and the offending line of code is the second line of this if block:

	if (!error && dev->class && dev->class->resume) {
		dev_dbg(dev,"class resume\n");
		error = dev->class->resume(dev);
	}

Hopefully some of this helps.
Comment 7 Richard Hughes 2009-04-15 12:13:37 EDT
Does this still happen with the version in fedora rawhide, or the version of the Fedora 11 beta live cd?
Comment 8 Bug Zapper 2009-06-09 20:11:23 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-07-14 11:09:17 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.