Bug 442503 - gpk-application doesnt filter available packages properly
gpk-application doesnt filter available packages properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 03:15 EDT by Jeremy West
Modified: 2008-11-06 05:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 550876 (view as bug list)
Environment:
Last Closed: 2008-11-06 05:59:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy West 2008-04-15 03:15:04 EDT
Description of problem:
pk-application no longer shows duplicate entries for installed packages, however
now if I choose to filter out only available packages, pk-application still
shows me packages I've just installed, even though I can drop the filter and
clearly see the package is installed.  

Version-Release number of selected component (if applicable):
gpk-application 0.1.12

How reproducible:
Every time


Steps to Reproduce:
1.  Bring up gpk-application
2.  Select a category and install a package not currently installed
3.  Once the package finishes installing, note that it now shows as installed in
the category list
4.  Now sort the category to only show "available" packages.
5.  Notice the package is now "greyed out" and showing as still available for
install
  
Actual results:
gpk-application doesn't filter results correctly.

Expected results:
gpk-application should filter results correctly.

Additional info:
Comment 1 Richard Hughes 2008-04-15 16:44:19 EDT
Should be fixed, could you give the newest packages from Rawhide a go please.
Thanks.
Comment 2 Jeremy West 2008-04-20 00:54:56 EDT
Richard ... I tested the latest packages and the problem still exists.  For
example.  If I open pkg-application and search in the KDE category I see
"dragon-player" listed.  IT's not installed so I install it.  After it's
installed, I see it no longer "greyed" out.  So I go to filter and only show
"available" packages.  Strangely "dragon-player" is still listed as a option,
when it was clearly just installed.

--jwest
Comment 3 Richard Hughes 2008-04-20 20:07:46 EDT
Well, I'm guessing this is because yum still counts a package as available even
when there's a nevra of the same version installed. I guess we'll have to filter
them in the yum backend, although that's pretty sucky.
Comment 4 Bug Zapper 2008-05-14 05:28:07 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Richard Hughes 2008-09-17 04:42:46 EDT
Should be fixed in the PackageKit in F9 and rawhide -- please confirm.

Note You need to log in before you can comment on or make changes to this bug.