This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442534 - java 6 crashed, it worked at least on fc5
java 6 crashed, it worked at least on fc5
Status: CLOSED DUPLICATE of bug 390261
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 08:48 EDT by Alexandre Efremov
Modified: 2008-04-15 17:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 17:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alexandre Efremov 2008-04-15 08:48:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080325 Fedora/2.0.0.13-1.fc8 Firefox/2.0.0.13

Description of problem:
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xc09737]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xc09891]
#2 /usr/lib/libX11.so.6(_XReply+0xff) [0xb4c12f]
#3 /usr/java/jdk1.6.0_05/jre/lib/i386/xawt/libmawt.so [0xb55d18ce]
#4 /usr/java/jdk1.6.0_05/jre/lib/i386/xawt/libmawt.so [0xb55ae067]
#5 /usr/java/jdk1.6.0_05/jre/lib/i386/xawt/libmawt.so [0xb55ae318]
#6 /usr/java/jdk1.6.0_05/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb55ae61f]
#7 [0xb5f28ecd]
#8 [0xb5f21edd]
#9 [0xb5f21edd]
#10 [0xb5f1f249]
#11 /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) [0x6272153]
#15 /usr/java/jdk1.6.0_05/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7f3a96d]
#16 [0xb5f28ecd]
#17 [0xb5f21d77]
#18 [0xb5f1f249]
#19 /usr/java/jdk1.6.0_05/jre/lib/i386/client/libjvm.so [0x621c40d]
java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
./rex.sh: line 1:  5843 Aborted                 java -classpath /usr/tibco/tibrv/lib/tibrvj.jar:../java/rvexplorer.jar:../java/jdom.jar:../java/crimson.jar -Djava.library.path=/usr/tibco/tibrv/lib com.tibco.rex.RvExplorer

Version-Release number of selected component (if applicable):
libxcb-1.1-1.fc7

How reproducible:
Always


Steps to Reproduce:
java -classpath /usr/tibco/tibrv/lib/tibrvj.jar:../java/rvexplorer.jar:../java/jdom.jar:../java/crimson.jar -Djava.library.path=/usr/tibco/tibrv/lib com.tibco.rex.RvExplorer

Actual Results:


Expected Results:


Additional info:
Comment 1 Jack Deslippe 2008-04-15 17:34:07 EDT
This a duplicate of many bugs on here for Fedora 8.  It seems to have just
cropped up in Fedora 7.

This bug is described here: 
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

The problem is AWT and xcb are not currently compatible.  A solution is to run
something similar to the following:

sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/java/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

(changing your path)

*** This bug has been marked as a duplicate of 390261 ***

Note You need to log in before you can comment on or make changes to this bug.