Bug 442594 - difference in merge behavior [i.e kdiff3] between mercurial 0.9.5 and 1.0
difference in merge behavior [i.e kdiff3] between mercurial 0.9.5 and 1.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mercurial (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Neal Becker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 14:38 EDT by Satish Balay
Modified: 2008-04-16 11:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-16 09:24:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mergetools patch (595 bytes, patch)
2008-04-16 07:13 EDT, Neal Becker
no flags Details | Diff

  None (edit)
Description Satish Balay 2008-04-15 14:38:07 EDT
Description of problem:

Hg merge brings up kdiff3 automatically with mercurial 0.9.5 - but not with 1.0

Version-Release number of selected component (if applicable):

mercurial-0.9.5-6.fc8
mercurial-1.0-12.fc8

How reproducible:

always

Steps to Reproduce:
1. create a repo [and a clone] with merge conflict
2. do 'hg merge' with both versions of mercurial
3.
  
Actual results:

<<<< 0.9.5 >>>>>>
asterix:/home/balay/tmp/bar>hg merge
resolving manifests
merging foobar
kbuildsycoca running...

<<<< 1.0 >>>>>>
asterix:/home/balay/tmp/bar>hg merge
resolving manifests
merging foobar
warning: conflicts during merge.
merging foobar failed!
0 files updated, 0 files merged, 0 files removed, 1 files unresolved
There are unresolved merges, you can redo the full merge using:
  hg update -C 1
  hg merge 2
asterix:/home/balay/tmp/bar>

Expected results:

kdiff3 invocation with 'hg merge'

Additional info:

The old behavior is restored by adding the following to ~/.hgrc as per
http://www.selenic.com/mercurial/wiki/index.cgi/.hgrc

[merge-tools]
kdiff3.args = $base $local $other -o $output
kdiff3.priority = 1

So there are 2 issues here..

- Should kdiff3 be the default mergetool - as before?
- the default kdiff3.args is in /etc/mercurial/hgrc.d/mergetools.hgrc is
incorrect? [If I don't redefine kdiff3.args - the kdif3 gui is invoked
incorrectly - with only 3 windows - instead of 4 - I normally see]
Comment 1 Neal Becker 2008-04-16 07:13:02 EDT
Created attachment 302579 [details]
mergetools patch
Comment 2 Neal Becker 2008-04-16 09:24:33 EDT
OK, closing
Comment 3 Satish Balay 2008-04-16 09:59:43 EDT
Looks like the above change is not required. [I tried it - and it didn't work].

The primary problem is - the config file is named mergetools.hgrc. It should
be renamed to mergetools.rc

[with the wrong name - it was not being read in]

After renaming the file - 'hg merge' brought up kdiff3, and it worked correctly.
Comment 4 Neal Becker 2008-04-16 11:18:40 EDT
Yes, the rename is fixed also in 1.0-13.

Note You need to log in before you can comment on or make changes to this bug.