Bug 442610 - anaconda fails to download a package missing in preupgrade's directory
anaconda fails to download a package missing in preupgrade's directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-04-15 15:35 EDT by Michal Schmidt
Modified: 2008-04-21 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: anaconda-11.4.0.74-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 19:00:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Schmidt 2008-04-15 15:35:59 EDT
Description of problem:

Preupgrade tries to download all the packages needed for a successful upgrade to
disk before rebooting to anaconda. Since preupgrade uses the original yum from
the current installation and anaconda uses the new yum, it sometimes happens the
two yum versions calculate a different set of packages for the upgrade and
therefore some packages can be missing in preupgrade's directory on the disk.
In such case anaconda should be able to download the missing packages from a
standard mirror.
The problem is anaconda does not set up the network, so the download fails and
the upgrade can't proceed.
In my case I was upgrading from F7 to Rawhide and the missing package was
compat-expat1.

Version-Release number of selected component (if applicable):

I hit the bug on 2008-04-13, so I guess it was:
anaconda-11.4.0.71-1

Steps to reproduce:
Deleting an RPM from /var/cache/yum/anaconda-upgrade/packages before rebooting
into the upgrade environment should do it.
Comment 1 Jeremy Katz 2008-04-15 15:38:08 EDT
Breaks a new feature in a pretty substantial way and I have a patch that at
least should work locally, it just needs to be tested.  So sticking on the
blocker list.
Comment 2 Jeremy Katz 2008-04-17 02:11:04 EDT
And cleaned up the patch to where it's working and pushed to git.
Comment 3 Will Woods 2008-04-17 17:32:42 EDT
This isn't in F9PR (anaconda-11.4.0.73) but should appear in the next anaconda
build.
Comment 4 Will Woods 2008-04-21 19:00:57 EDT
Confirmed fixed in anaconda-11.4.0.74. Yay!

Note You need to log in before you can comment on or make changes to this bug.