Bug 442633 - Error running livecd-creator with no lvm on host
Error running livecd-creator with no lvm on host
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 17:52 EDT by Davidson Paulo
Modified: 2008-07-02 02:34 EDT (History)
4 users (show)

See Also:
Fixed In Version: 013.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-02 02:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file used to build the live media. (1.35 KB, text/plain)
2008-04-15 17:52 EDT, Davidson Paulo
no flags Details

  None (edit)
Description Davidson Paulo 2008-04-15 17:52:25 EDT
Description of problem:

livecd-creator does not build a live media due to a problem on umounting the
loop device used to install the live system in.

Version-Release number of selected component (if applicable):

kernel-2.6.24.4-64.fc8
livecd-tools-013-1.fc8
yum-3.2.8-2.fc8

How reproducible:

Try to build a live media.

Steps to Reproduce:

1. Take a kickstart file
2. Call livecd-creator to build a live media from the kickstart file.
3. Wait a lot of time

Actual results:

1. You get an error on the last step of the process
2. You stay frustrated  

Expected results:

1. You get your live media ISO
2. You stay happy

Additional info:

Here is the command typed and the error message as well:

# livecd-creator -c ~dpaulo/fedora-full.ks --cache=/srv/revisor/livecd-cache/
--fslabel=F-8-Live-1
(...)
Installing: system-config-keyboard ##################### [533/533]
umount: /var/tmp/livecd-creator-dXy9yh/install_root: device is busy
umount: /var/tmp/livecd-creator-dXy9yh/install_root: device is busy
ioctl: LOOP_CLR_FD: Device or resource busy
Traceback (most recent call last):
File "/usr/bin/livecd-creator", line 1603, in
sys.exit(main())
File "/usr/bin/livecd-creator", line 1575, in main
target.install()
File "/usr/bin/livecd-creator", line 948, in install
self.installPackages()
File "/usr/bin/livecd-creator", line 602, in installPackages
%(self.build_dir, subdir)):
OSError: [Errno 2] No such file or directory:
'/var/tmp/livecd-creator-dXy9yh/install_root/etc/lvm/cache'

The kickstart file used is attached.
Comment 1 Davidson Paulo 2008-04-15 17:52:25 EDT
Created attachment 302531 [details]
Kickstart file used to build the live media.
Comment 2 Paul W. Frields 2008-04-17 09:14:00 EDT
https://www.redhat.com/archives/fedora-livecd-list/2008-April/msg00094.html

Just in case that ends up being helpful.
Comment 3 Andreas Zuber 2008-05-16 11:42:34 EDT
I had the same problem. After i disabled selinux the problem was gone.
Comment 4 Jeremy Katz 2008-05-27 15:22:33 EDT
You don't have any LVM in use on your system?  This should be fixed in teh
version in F9.  Can you grab http://katzj.fedorapeople.org/livecd-creator and
see if it fixes things also?
Comment 5 Jeremy Katz 2008-06-16 11:05:59 EDT
New package will be going into -updates-testing for Fedora 8 with this fix later
today
Comment 6 Fedora Update System 2008-06-16 11:15:45 EDT
livecd-tools-013.1-1.fc8 has been submitted as an update for Fedora 8
Comment 7 Fedora Update System 2008-06-17 23:14:58 EDT
livecd-tools-013.1-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update livecd-tools'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-5423
Comment 8 Fedora Update System 2008-07-02 02:34:20 EDT
livecd-tools-013.1-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.