Bug 442637 - evdev driver does not work under F8/KVM
evdev driver does not work under F8/KVM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-evdev (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Peter Hutterer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-15 18:53 EDT by Geert Jansen
Modified: 2013-03-13 02:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-14 22:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg configuration file (724 bytes, text/plain)
2008-04-15 18:53 EDT, Geert Jansen
no flags Details
Xorg log file (31.44 KB, text/plain)
2008-04-15 18:54 EDT, Geert Jansen
no flags Details
libvirt xml config (853 bytes, text/xml)
2008-04-15 18:57 EDT, Geert Jansen
no flags Details

  None (edit)
Description Geert Jansen 2008-04-15 18:53:45 EDT
Description of problem:

The "evdev" mouse driver does not work in RHEL5b1 when run as a virtual guest
under Fedora 8/KVM.

Version-Release number of selected component (if applicable):

[root@rhel52b1 X11]# rpm -q xorg-x11-drv-evdev
xorg-x11-drv-evdev-1.0.0.5-3.el5

How reproducible:

Everytime

Steps to Reproduce:

1. Install Fedora 8 with KVM.
2. Install RHEL5b1 as a virtual guest.
3. Configure the "evdev" driver for the mouse.
4. Start up X: exists with the following error message:
  
Actual results:

X exits with the following error message:

(EE) ioctl EVIOCGBIT failed: Inappropriate ioctl for device
(EE) PreInit returned NULL for "Mouse0"
No core pointer

Fatal server error:
failed to initialize core devices

Expected results:

X starts up normally.

Additional info:

I have attached my Xorg configuration and log file.
Comment 1 Geert Jansen 2008-04-15 18:53:45 EDT
Created attachment 302532 [details]
Xorg configuration file
Comment 2 Geert Jansen 2008-04-15 18:54:59 EDT
Created attachment 302533 [details]
Xorg log file
Comment 3 Geert Jansen 2008-04-15 18:57:32 EDT
Created attachment 302534 [details]
libvirt xml config
Comment 4 Peter Hutterer 2008-07-14 22:47:42 EDT
Geert:
the device /dev/input/mouse1 is not a valid evdev device. Instead, you need to
specify /dev/input/event1, or even better the appropriate entry
/dev/input/by-id/... or /dev/input/by-path/...

Note that you can specify a device only when it is not in used by the host system.

Changing to NOTABUG, caused by misconfiguration.

Note You need to log in before you can comment on or make changes to this bug.