Bug 442641 - maven-wagon lacks WebDAV provider
Summary: maven-wagon lacks WebDAV provider
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: maven-wagon   
(Show other bugs)
Version: 9
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Matt Wringe
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-15 23:24 UTC by Conrad Meyer
Modified: 2009-03-21 00:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-21 00:26:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Conrad Meyer 2008-04-15 23:24:45 UTC
Description of problem:
I'm trying to package xstream, a java library to serialize objects to XML (and 
back). It depends upon the WebDAV component of maven-wagon. I would like this 
component to be included in Fedora's maven-wagon package.


Version-Release number of selected component (if applicable):
1.0-0.1.a5.3jpp.1


How reproducible:
Always.


Additional info:
Sorry Matt -- I should have filed here first.

Comment 1 Matt Wringe 2008-04-16 15:02:05 UTC
The version of maven-wagon currently in fedora doesn't have the WebDAV
component. To get the new version with WebDAV support will require bringing in a
bunch of new dependencies (WebDAV, slide (or possible jackrabbit), and all of
their dependencies). 

Does xstream actually need WebDAV? is it used as part of the core, as a separate
plugin, or just during building (ie for writing tests, or for running some other
maven plugin that not a requirement).

Comment 2 Conrad Meyer 2008-04-16 16:19:29 UTC
I don't know if it actually needs it or not; I don't know much about maven. I 
followed the maven java packaging guidelines template spec, and the builds 
fails because it's missing the WebDAV provider.

Comment 3 Bug Zapper 2008-05-14 09:30:36 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Conrad Meyer 2009-03-21 00:26:06 UTC
Closing as I don't care about this package (xstream) anymore.


Note You need to log in before you can comment on or make changes to this bug.