Bug 442659 - broken, again (still?)
broken, again (still?)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-15 22:37 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 11:45:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-15 22:37:07 EDT
Description of problem:

Attempting to connect yields:

NetworkManager: <info>  Starting VPN service
'org.freedesktop.NetworkManager.vpnc'...
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc'
started (org.freedesktop.NetworkManager.vpnc), PID 3983
NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.vpnc' just
appeared, activating connections
NetworkManager: <info>  VPN plugin state changed: 1
NetworkManager: <info>  VPN plugin state changed: 3
** Message: <info>  vpnc started with pid 3989

NetworkManager: <info>  VPN connection '<blah>' (Connect) reply received.
/usr/sbin/vpnc: warning: unknown configuration directive in stdin at line 2
/usr/sbin/vpnc: warning: unknown configuration directive in stdin at line 3
/usr/sbin/vpnc: warning: unknown configuration directive in stdin at line 4
/usr/sbin/vpnc: noninteractive can't reuse password

** (process:3983): WARNING **: <WARN>  vpnc_watch_cb(): vpnc exited with error
code 1

NetworkManager: <info>  VPN plugin state changed: 6
NetworkManager: <WARN>  connection_state_changed(): Could not process the
request because no VPN connection was active.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.0-0.9.1.svn3549.fc9.x86_64
NetworkManager-vpnc-0.7.0-0.7.7.svn3549.fc9.x86_64
Comment 1 Dan Williams 2008-04-16 12:54:20 EDT
Are you sure your password is correct?  I think if the server rejects you once,
and if vpnc is running in non-interactive mode, it will just quit.  See
do_phase_2_xauth() in vpnc.c.
Comment 2 Bill Nottingham 2008-04-16 13:24:14 EDT
What exactly do you have to kill to get it to ask for the password again?
Killing all of:
- NetworkManager
- nm-vpnc-server
- nm-system-settings
- nm-applet

does not help.
Comment 3 Dan Williams 2008-04-16 15:19:04 EDT
you get to remove the password from the keyring with gnome-keyring-manager.  you
can also see the password there unobfuscated to ensure that it's correct.

Note You need to log in before you can comment on or make changes to this bug.