Bug 442663 - apparently corrupt: releases/8/Everything/x86_64/debug/chkconfig-debuginfo-1.3.36-1.x86_64.rpm
apparently corrupt: releases/8/Everything/x86_64/debug/chkconfig-debuginfo-1....
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 00:52 EDT by D. Hugh Redelmeier
Modified: 2008-05-30 11:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-30 11:11:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description D. Hugh Redelmeier 2008-04-16 00:52:32 EDT
Description of problem:
debuginfo-install chokes on chkconfig-debuginfo

Version-Release number of selected component (if applicable):
chkconfig-debuginfo-1.3.36-1.x86_64.rpm

How reproducible:
every time I try


Steps to Reproduce:
1. debuginfo-install qemu

  
Actual results:
a lot of messages looking like this, for each repo tried:
Downloading Packages:

(1/1): chkconfig-debuginf 100% |=========================|  79 kB    00:00
http://www.muug.mb.ca/pub/fedora/linux/releases/8/Everything/x86_64/debug/chkconfig-debuginfo-1.3.36-1.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.
(1/1): chkconfig-debuginf 100% |=========================|  79 kB    00:00
ftp://wuarchive.wustl.edu/pub/linux/distributions/fedora/releases/8/Everything/x86_64/debug/chkconfig-debuginfo-1.3.36-1.x86_64.rpm:
[Errno -1] Package does not match intended download
Trying other mirror.


Expected results:
proper download and installation of chkconfig-debuginfo

Additional info:
This command works:
debuginfo-install -x chkconfig-debuginfo qemu
This is why I think that the file is corrupted and not that the
debuginfo-install command buggy.

The diagnostic generated by debuginfo-install is not very clear or helpful.
Comment 1 D. Hugh Redelmeier 2008-04-16 01:07:53 EDT
Maybe I spoke to hastily.  I downloaded and checked the file and it seems fine:
$ rpm --checksig Desktop/chkconfig-debuginfo-1.3.36-1.x86_64.rpm 
Desktop/chkconfig-debuginfo-1.3.36-1.x86_64.rpm: (sha1) dsa sha1 md5 gpg OK

But "debuginfo-install qemu" still fails.

This was not improved by any of the following which I tried in turn:
yum clean dbcache
yum clean metadata
yum clean headers
Comment 2 Bill Nottingham 2008-04-16 10:16:42 EDT
I just did 'debuginfo-install qemu' on a test Fedora 8 VM instance here and it
worked OK.

Note You need to log in before you can comment on or make changes to this bug.