Bug 442669 - Printing errors: overlaping characters in Firefox 2.0.0.13
Printing errors: overlaping characters in Firefox 2.0.0.13
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 01:48 EDT by Gian Paolo Mureddu
Modified: 2008-04-19 20:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 06:22:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of how print-to-file looks in Evince, which is the same as on paper. (87.79 KB, image/jpeg)
2008-04-16 01:48 EDT, Gian Paolo Mureddu
no flags Details
reproducing the issue (262.56 KB, application/postscript)
2008-04-17 09:48 EDT, Matěj Cepl
no flags Details
My current output in F8 x86_64 FF 2.0.0.13 (312.67 KB, application/postscript)
2008-04-17 18:16 EDT, Gian Paolo Mureddu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 429638 None None None Never

  None (edit)
Description Gian Paolo Mureddu 2008-04-16 01:48:47 EDT
Description of problem:
Printing and printing to file with Firefox-2.0.0.13, causes "compressed words
and pharases". I'm not sure what the problem is exactly. Thus far I've seen it
in i386 and x86_64 Firefox; and on Fedora 7 and 8. I thought I had reported this
problem another time with Firefox and printing (and printing to file) and
apparently the consensus was that this was an upstream problem on how did
Firefox handled the PostScript conversion of the data or something along those
lines. At any rate, I've come across this problem again, and I'm not sure if it
was fixed "the first" time. By the way what I see in the print-to-file and print
to paper "print-outs" is the same.

Version-Release number of selected component (if applicable):
firefox-2.0.0.13-1.fc8.i386
firefox-2.0.0.13-1.fc8.x86_64
firefox-2.0.0.13-1.fc7.i386
firefox-2.0.0.13-1.fc7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open a page with text.
2. Print or print-to-file.
  
Actual results:
See attached file.

Expected results:
The print-out to be normal...
Comment 1 Gian Paolo Mureddu 2008-04-16 01:48:47 EDT
Created attachment 302550 [details]
Screenshot of how print-to-file looks in Evince, which is the same as on paper.
Comment 2 Gian Paolo Mureddu 2008-04-16 02:05:58 EDT
Forgot to mention this doesn't happen with Konqueror, but does happen with other
Gecko-based browsers (Galeon and Epiphany), the difference seems to be the
degree of "deformation" they produce in the print-out. Also firefox and Gecko
based browsers in F8 seem to deform only certain parts of the documents, but
instead of still being legible, some lines are but a black stain.
Comment 3 Matěj Cepl 2008-04-16 08:10:57 EDT
Could I ask for some webpage, where you can reproduce it, or is the problem same
regardless of URL?
Comment 4 Gian Paolo Mureddu 2008-04-17 00:07:48 EDT
Actually, that's what's bugging me. I seem to be unable to determine which do
and which don't... However, I needed to print something out of this site (I'm
registering to enter a medical residency in my country)... I was able to
reproduce the problem in the site's application information:
http://www.cifrhs.org.mx/contenidos/seccion_academica/residencias_medicas/convocatoria08/inscripcion_medicos_mexicanos.html

What I did to test this was to print-to-file the page and see that on page 2 in
point 3 paragraphs A and B the first line is "compressed" (F8) or the whole
paragraphs are mangled (F7).
Comment 5 Matěj Cepl 2008-04-17 09:48:51 EDT
Created attachment 302749 [details]
reproducing the issue

The result of printing the suggested page with Firefox3
Comment 6 Gian Paolo Mureddu 2008-04-17 18:16:32 EDT
Created attachment 302825 [details]
My current output in F8 x86_64 FF 2.0.0.13

Your output is much better than mine, no doubt. I see a bit strange the fonts,
but I guess that's because of the different fonts set across our systems
(especially if you are running FF3Beta in F9 Beta, as I'd assume you do)
Comment 7 Matěj Cepl 2008-04-18 06:22:33 EDT
We filed this bug in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=429638) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.
Comment 8 Gian Paolo Mureddu 2008-04-19 20:25:20 EDT
Yes. Last time I had to deal with this it was said that this was an upstream
bug, however I do consider this is to be of a high priority and impact, as many
users depend on appropriate printing from the web browser. Especially being this
the default browser for not only Fedora or RHEL, but many other distributions. I
should have mentioned in the original report, that this problem doesn't show in
the Windows version of Firefox, so I'm not sure if it is the inherent mechanism
Mozilla is using to translate to PostScript or if some other library in the
Linux version is causing this. I couldn't say if this is the same on the MacOS
version of Firefox, as I have no access to a Mac nor a MacOS.

I hope they get this worked out soon, though.

Note You need to log in before you can comment on or make changes to this bug.