Bug 442676 - Clutter cairo missing
Clutter cairo missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: clutter (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Allisson Azevedo
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 03:53 EDT by Karl Lattimer
Modified: 2008-11-05 09:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-05 09:12:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
clutter-cairo.spec (1.54 KB, application/octet-stream)
2008-05-20 11:45 EDT, Rick L Vinyard Jr
no flags Details

  None (edit)
Description Karl Lattimer 2008-04-16 03:53:29 EDT
The clutter cairo package is missing since the transition to clutter 0.6.
Comment 1 MartinG 2008-05-16 17:11:59 EDT
I can confirm that clutter cairo is missing (or at least that I can't find it 
in the F8 repo).
Comment 2 MartinG 2008-05-16 17:23:46 EDT
Additional info:
"[clutter] [ANNOUNCE] Clutter Cairo 0.6.1":
http://lists.o-hand.com/clutter/1043.html

Clutter Cairo 0.6.1 is now available for download at: 
  http://www.clutter-project.org/sources/clutter-cairo/0.6/

Comment 3 Rick L Vinyard Jr 2008-05-20 11:45:13 EDT
Created attachment 306141 [details]
clutter-cairo.spec

Until there is an official clutter-cairo package, this spec file based on
clutter-gtk will provide the clutter-cairo library.

To build from the spec see:
http://fedoraproject.org/wiki/Docs/Drafts/BuildingPackagesGuide

But, the short version is:

1. Get the tarball: spectool -g clutter-cairo.spec
2. Copy the tarball to your build tree (typically ~/rpmbuild/SOURCES or
/usr/src/redhat/SOURCES)
3. Build: rpmbuild -ba clutter-cairo.spec

Allisson: 
I didn't submit the package since I really don't want to maintain it unless
absolutely necessary, but feel free to use it in any way you want.

I also have a cluttermm spec file that depends on clutter-cairo since the
cluttermm package builds C++ bindings for clutter, clutter-gtk and
clutter-cairo.

If you want it, you're welcome to the cluttermm.spec file as well, but I was
planning on sending it to Dennis Leroy since he maintains most of the *mm
(gtkmm, cairomm, libsexymm, et. al.) stuff.
Comment 4 Allisson Azevedo 2008-05-20 13:12:06 EDT
Rick:

Thanks for spec, i'll submit clutter-cairo, clutter-perl and clutter-vala for
review soon as possible.

Dennis is a better choice for maintain clutermm.

Cheers
Comment 5 Karl Lattimer 2008-11-05 09:12:16 EST
with 0.8.x it appears to be present. closing the bug

Note You need to log in before you can comment on or make changes to this bug.