Bug 442697 - The installation is stopped without error message, when we skip to input Install Media URL.
The installation is stopped without error message, when we skip to input Inst...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 06:50 EDT by Adam Stokes
Modified: 2010-10-22 20:09 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0480
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:29:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Catch empty install path and raise error (772 bytes, patch)
2008-04-17 10:15 EDT, Cole Robinson
no flags Details | Diff
Fixed patch to catch empty install (782 bytes, patch)
2008-04-22 11:36 EDT, Cole Robinson
no flags Details | Diff

  None (edit)
Description Adam Stokes 2008-04-16 06:50:02 EDT
Description of problem:
 We get no reply from virt-manager when we skip to input
in the path of Install Media URL. So, we cannot continue
to install.
This is a Regression issue, since it does not occur on RHEL5.1.

Version-Release number of selected component (if applicable):
virt-manager 0.5.x

How reproducible:
100%

Steps to Reproduce:
 1. Start virt-manager.
2. Click [New] button.
3. Select [Paravirtualized], and click [Forward] button.
4. Click [Forward] button without filling in the path of install media.
  
Actual results:
 We cannot proceed the installation.

Expected results:
 The virt-manager says the error message (like 'URL error'),
when we skip to input the path of install media URL.

Additional info:
 This issue is fixed by following patch.
http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs= 4f53f0727530
Comment 1 RHEL Product and Program Management 2008-04-16 06:55:52 EDT
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.
Comment 2 Cole Robinson 2008-04-17 10:15:46 EDT
Created attachment 302750 [details]
Catch empty install path and raise error
Comment 3 Cole Robinson 2008-04-17 10:17:20 EDT
This bug is not very intrusive but it is a matter of polish, and since it's a
regression we should fix this. The patch itself is trivial and virtually no risk
as well.
Comment 5 Cole Robinson 2008-04-22 11:36:55 EDT
Created attachment 303330 [details]
Fixed patch to catch empty install

Upstream patch originally posted used an internal method that isn't available
in rhel5. Simple change, now works as expected.
Comment 6 Cole Robinson 2008-04-22 12:31:10 EDT
Built into virt-manager-0.5.3-8

$ brew latest-pkg dist-5E-qu-candidate virt-manager
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
virt-manager-0.5.3-8.el5                  dist-5E-qu-candidate  crobinso
Comment 9 errata-xmlrpc 2008-05-21 13:29:21 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0480.html

Note You need to log in before you can comment on or make changes to this bug.