Bug 442711 - hwclock cannot access the Hardware Clock
hwclock cannot access the Hardware Clock
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: util-linux-ng (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 08:20 EDT by Ilkka Tengvall
Modified: 2008-04-18 01:53 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 01:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmidecode, lspci -vvv, cpuinfo, lsmod (59.73 KB, text/plain)
2008-04-16 08:20 EDT, Ilkka Tengvall
no flags Details

  None (edit)
Description Ilkka Tengvall 2008-04-16 08:20:35 EDT
Description of problem:

hwclock can not get a hold on hardware clock. This causes ntpd to fail also, I
assume.

Version-Release number of selected component (if applicable):
util-linux-ng-2.13.1-6.fc9.x86_64

How reproducible:
every time

Steps to Reproduce:
1. do "hwclock --show" as root
2.
3.
  
Actual results:

hwclock --rtc=/dev/rtc0 --debug --show
hwclock from util-linux-ng 2.13.1
hwclock: Open of /dev/rtc0 failed, errno=16: Device or resource busy.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.

Expected results:
Show/set system time correctly.


Additional info:

[root@whipper ~]# cat /sys/class/rtc/rtc0/dev
254:0
[root@whipper ~]# ls -lZ /dev/rtc0
crw-r--r--  root root system_u:object_r:clock_device_t:s0 /dev/rtc0
[root@whipper ~]# ls -l /dev/rtc0
crw-r--r-- 1 root root 254, 0 2008-04-16 19:56 /dev/rtc0
Comment 1 Ilkka Tengvall 2008-04-16 08:20:35 EDT
Created attachment 302590 [details]
dmidecode, lspci -vvv, cpuinfo, lsmod
Comment 2 Karel Zak 2008-04-16 09:39:51 EDT
Why do you need to use the option --rtc? Without this option hwclock(8) is
trying to open other clock devices.

It would be nice to check logs for AVC denial messages too.
Comment 3 Ilkka Tengvall 2008-04-18 01:53:16 EDT
Today I received new kernel via updates. I don't know if it was that, but
hwclock started working.

Kzak: No, I did not see AVC denials and it was the same without --rtc, I just
tried to force it for the right clock if it would not have found it otherwise.

Works now, so the bug can be closed.

Note You need to log in before you can comment on or make changes to this bug.