Bug 442738 - sr# 1796308 - Mesa/ libGL warning: 3D driver claims to not support visual 0x5b
sr# 1796308 - Mesa/ libGL warning: 3D driver claims to not support visual 0x5b
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mesa (Show other bugs)
5.1
All Linux
high Severity medium
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
: Triaged
Depends On:
Blocks: 726826
  Show dependency treegraph
 
Reported: 2008-04-16 11:08 EDT by Alan Matsuoka
Modified: 2012-02-21 01:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 01:48:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to glext.c (704 bytes, text/x-patch)
2008-04-16 11:08 EDT, Alan Matsuoka
no flags Details
sosreport (552.04 KB, application/x-bzip2)
2008-04-16 11:09 EDT, Alan Matsuoka
no flags Details

  None (edit)
Description Alan Matsuoka 2008-04-16 11:08:27 EDT
Description of problem:
 Users are encountering problems using IDL software - they encounter a message
"libGL warning: 3D driver claims to not support visual 0x5b", and the
application segfaults.

 The issue of segfaulting was traced to the application. With the attached
patch, software runs 8-10% faster.

How reproducible:
n/a

Steps to Reproduce:
n/a

Actual results:
n/a

Expected results:
n/a

Additional info:
upstream bug -
https://bugs.freed esktop.org/show_bug.cgi?id=6689


**** Problem Description
Source : Service Request 1796308
Created by : UCLMSSL
Created on : 13-Feb-2008 07:10:40
It does help.

>>  http://www.ittv is.com/services/techtip.asp?ttid=4177
Grr, substandard proprietary packages... (IDL I mean)
I'll do what I can to get licensing updated for IDL 6.4 or later.


>> Your updated packages do work and work significantly faster for 3D programs.
>* If i understand this corectly, with the _TEST_ package performace is
>> significantly faster over the package provided with RHEL5 ?

Yes. The speedup is about 8-10%


>> It would still be worthwhile updating to 6.5.2...
>* This would need a good amount of work from QA. We tend to backport security
>> fixes, and enhancements as requested to minimize any disruptive changes.

I'm aware of that. It's one of those cases of most of the changes being bugfixes
and the feature changes being useful (DRI working for various chipsets) with no
apparent major changes and no symbol changes.

http://www.mesa3d.org/reln otes-6.5.2.html

6.5.3 contains a few more bugfixes...

http://www.mesa3d.org/reln otes-6.5.3.html

If the preferred method is a backport then that's fine.



>> Setting LIBGL_ALWAYS_INDIRECT solves the problem on affected systems.
>* This switch enables software rendering, and will should be slower than
hardware based redering.

I'm painfully aware of that (approx 1/3 the speed of hardware rendering) but
it's better than segfaulting... 

Note from alanm:

Just so that we know where the patch came from; this patch is not from
Mesa-6.5.3 but is in Mesa-7.0.2.
Comment 1 Alan Matsuoka 2008-04-16 11:08:28 EDT
Created attachment 302614 [details]
patch to glext.c
Comment 2 Alan Matsuoka 2008-04-16 11:09:53 EDT
Created attachment 302615 [details]
sosreport
Comment 3 RHEL Product and Program Management 2008-06-02 16:05:55 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Adam Jackson 2008-06-23 11:00:40 EDT
That patch just hides the warning message.  Which is certainly the correct thing
to do, but it won't solve the segfault they're seeing.  Are we trying to fix
that here too?
Comment 5 Alan Matsuoka 2008-06-23 11:05:18 EDT
As far as I can tell, just the message. The segfaulting problem is in the
application code and its proprietary.
Comment 6 ritz 2008-06-23 15:54:43 EDT
as per the customer, apparently hiding the message boosts the performance of
proprietary application by upto 40%. beats me. 
Comment 8 RHEL Product and Program Management 2009-03-26 13:00:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Alan Matsuoka 2009-03-26 13:27:48 EDT
Moving again to 5.5
Comment 12 RHEL Product and Program Management 2010-08-09 14:54:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 14 Adam Jackson 2011-02-16 15:30:27 EST
devel ack, trivial
Comment 18 RHEL Product and Program Management 2011-08-12 05:09:58 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 21 Vladimir Benes 2011-10-12 10:48:56 EDT
cannot reproduce on this graphics.. is this the right one? is it possible this bug has been fixed already?

0000:0a:00.0 VGA compatible controller [0300]: nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] [10de:0161] (rev a1) (prog-if 00 [VGA controller])
	Subsystem: nVidia Corporation Device [10de:025e]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 5
	Region 0: Memory at f0000000 (32-bit, non-prefetchable) [size=16M]
	Region 1: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 3: Memory at f1000000 (64-bit, non-prefetchable) [size=16M]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [60] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
	Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 0000000000000000  Data: 0000
	Capabilities: [78] Express (v1) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <4us
			ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
			MaxPayload 128 bytes, MaxReadReq 512 bytes
		DevSta:	CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Latency L0 <1us, L1 <4us
			ClockPM- Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-
			ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x16, TrErr- Train- SlotClk- DLActive- BWMgmt- ABWMgmt-
	Kernel modules: nvidiafb
Comment 22 David Mair 2011-10-15 19:17:16 EDT
Can we get the QA ack on this. Mesa has not been on the ACL since 5.3 and we need to get this bug closed out considering how old this is and that we do actually have a patch proposed for this.
Comment 23 Alan Matsuoka 2011-10-16 13:13:01 EDT
I haven't seen it on NV hardware. The last time I saw this was on a laptop sometime ago with Intel graphics.
Comment 28 Adam Jackson 2011-11-10 10:46:04 EST
3793900 build (dist-5E-qu-candidate, /cvs/dist:rpms/mesa/RHEL-5:mesa-6_5_1-7_10_el5) completed successfully

MODIFIED
Comment 31 errata-xmlrpc 2012-02-21 01:48:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0288.html

Note You need to log in before you can comment on or make changes to this bug.