Bug 442746 - Autodetect both Geode GX and LX
Summary: Autodetect both Geode GX and LX
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-04-16 15:42 UTC by Warren Togami
Modified: 2008-04-21 20:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 20:11:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg-server-20080415-geode-autoconfig.patch (546 bytes, patch)
2008-04-16 15:42 UTC, Warren Togami
no flags Details | Diff

Description Warren Togami 2008-04-16 15:42:07 UTC
About a month ago ajax said he would change amd to geode in xorg-x11-server in
order to match the upstream name change.  I discovered now that this didn't
happen in F9.

The attached patch makes it properly detect both Geode GX and LX in exactly the
same manner as F-8 xorg-x11-server.

I was not able to test this patch yet.

Risk is negligible because it is broken without this patch.

Comment 1 Warren Togami 2008-04-16 15:42:07 UTC
Created attachment 302625 [details]
xorg-server-20080415-geode-autoconfig.patch

Comment 2 Adam Jackson 2008-04-16 17:53:43 UTC
The amd driver build in F9 installs files named both amd_drv.so and
geode_drv.so.  Why do you think this doesn't work?

Comment 3 Warren Togami 2008-04-16 19:56:07 UTC
OK, I was misreading a log from a different issue.

There are two other reasons for applying this patch:
1) We want to migrate people away from amd driver written in their config files.
 If people write new config files now it would have "geode" and not "amd".
2) The other hardware ID currently doesn't autoconfigure the geode driver.  This
patch ensures that both autoconfigure.


Comment 4 Adam Jackson 2008-04-21 19:53:14 UTC
The other PCI vendor ID doesn't actually _work_ in the geode driver.  So, no.

This is fixed upstream now, but since it works as-is in F9 I'm not going to
worry about pulling it into the 1.5 branch.  We'll use the 'geode' name in F10
though.


Note You need to log in before you can comment on or make changes to this bug.