This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442751 - anaconda does not create boot.iso on ia64
anaconda does not create boot.iso on ia64
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-04-16 12:34 EDT by Doug Chapman
Modified: 2008-06-21 16:25 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-21 16:25:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to replacemissing '/' in mkisofs command line (724 bytes, patch)
2008-04-16 16:47 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-04-16 12:34:47 EDT
Description of problem:
It appears this is a fallout of the changing from boot.iso to netinst.iso and
then back to boot.iso.  On ia64 we no longer get a boot.iso created.  I am
digging through the code now to understand why but figured I would file this
just in case it was an obvious fix to you guys.

The last version that worked OK appears to have been just before the commit:
6e48880d0b0aa76f139fdca081c5ca48c146ee82 Change the ISOs we build

Which should have still created netinst.iso as I understand it.  From that point
on we no longer got boot.iso or netinst.iso.


Version-Release number of selected component (if applicable):
anaconda-11.4.0.41-1 and later up through anaconda-11.4.0.71-1

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-04-16 16:47:24 EDT
Created attachment 302671 [details]
patch to replacemissing '/' in mkisofs command line

It appears the problem is we are missing a '/' in the command line of mkisofs
in mk-images.ia64.  I am testing with this fix now to ensure that is all that
is wrong but either way this patch is needed.
Comment 2 Doug Chapman 2008-04-16 18:30:07 EDT
I have confirmed that my above patch does indeed fix the missing boot.iso problem.
Comment 3 Jeremy Katz 2008-04-16 22:02:37 EDT
Applied
Comment 4 Doug Chapman 2008-04-18 14:02:51 EDT
Jeremy,

anaconda-11.4.0.73-2 still has this issue, the patch appears to not have been
applied yet.

- Doug
Comment 5 Jeremy Katz 2008-04-18 14:23:19 EDT
We haven't done a build since the patch was pushed (well, we did, but it was a
build with only a small targeted fix rather than top of the tree)
Comment 6 Bug Zapper 2008-05-14 05:32:19 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.