Bug 442765 - crashes attempting to debug rpm
crashes attempting to debug rpm
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-16 13:32 EDT by Bill Nottingham
Modified: 2014-03-16 23:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: 6.8-5.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-13 11:26:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2008-04-16 13:32:40 EDT
Description of problem:


$ gdb /bin/rpm
GNU gdb Fedora (6.8-1.fc9)
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu"...
(gdb) set args --define '_gpg_name Fedora Project <fedora@redhat.com>' --resign
 konq-plugins-4.0.3-0.1.20080409svn.fc9.ppc.rpm 
(gdb) 
(gdb) run
Starting program: /bin/rpm --define '_gpg_name Fedora Project
<fedora@redhat.com>' --resign  konq-plugins-4.0.3-0.1.20080409svn.fc9.ppc.rpm 
[Thread debugging using libthread_db enabled]
[New Thread 0x7fefdcdcd780 (LWP 8478)]
[New process 8478]
Executing new program: /usr/lib/rpm/rpmk
Missing separate debuginfos, use: debuginfo-install elfutils.x86_64 gcc.x86_64
libselinux.x86_64 popt.x86_64
warning: Cannot initialize thread debugging library: generic error
warning: Cannot initialize thread debugging library: generic error
[New process 8478]
[Thread debugging using libthread_db enabled]
Segmentation fault

Version-Release number of selected component (if applicable):

gdb-6.8-1.fc9.x86_64
Comment 1 Bill Nottingham 2008-04-16 13:34:27 EDT
Executing new program: /usr/lib/rpm/rpmk
Missing separate debuginfos, use: debuginfo-install elfutils.x86_64 gcc.x86_64
popt.x86_64
warning: Cannot initialize thread debugging library: generic error
warning: Cannot initialize thread debugging library: generic error
[New process 8704]
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fdacacd4780 (LWP 8686)]
0x000000000046664e in thread_get_info_callback (thp=0x7fffd2cf8690,
infop=0x7fffd2cf86a8) at /usr/include/bits/string3.h:52
warning: Source file is more recent than executable.
52	  return __builtin___memcpy_chk (__dest, __src, __len, __bos0 (__dest));
Missing separate debuginfos, use: debuginfo-install elfutils.x86_64 gcc.x86_64
popt.x86_64 readline.x86_64
(gdb) bt
#0  0x000000000046664e in thread_get_info_callback (thp=0x7fffd2cf8690,
infop=0x7fffd2cf86a8) at /usr/include/bits/string3.h:52
#1  0x00000000004668ab in thread_from_lwp (ptid={pid = 8704, lwp = 8704, tid =
0}) at ../../gdb/linux-thread-db.c:351
#2  0x0000000000466c9d in thread_db_wait (ptid={pid = 8704, lwp = 8704, tid =
0}, ourstatus=0x7fffd2cf8780) at ../../gdb/linux-thread-db.c:889
#3  0x00000000004e1e09 in wait_for_inferior (treat_exec_as_sigtrap=0) at
../../gdb/infrun.c:1042
#4  0x00000000004e2127 in proceed (addr=<value optimized out>,
siggnal=TARGET_SIGNAL_0, step=0) at ../../gdb/infrun.c:854
#5  0x00000000004dc1ae in run_command_1 (args=0x0, from_tty=1,
tbreak_at_main=<value optimized out>) at ../../gdb/infcmd.c:563
#6  0x000000000044677a in execute_command (p=0x114ca43 "", from_tty=1) at
../../gdb/top.c:449
#7  0x00000000004ed74b in command_handler (command=0x114ca40 "") at
../../gdb/event-top.c:523
#8  0x00000000004ee62c in command_line_handler (rl=<value optimized out>) at
../../gdb/event-top.c:809
#9  0x0000003062027e7e in rl_callback_read_char () from /lib64/libreadline.so.5
#10 0x00000000004eda69 in rl_callback_read_char_wrapper (client_data=0x0) at
../../gdb/event-top.c:178
#11 0x00000000004ec37d in process_event () at ../../gdb/event-loop.c:341
#12 0x00000000004ecd36 in gdb_do_one_event (data=<value optimized out>) at
../../gdb/event-loop.c:378
#13 0x00000000004e9884 in catch_errors (func=0x4ecb30 <gdb_do_one_event>,
func_args=0x0, errstring=0x647c6a "", mask=<value optimized out>) at
../../gdb/exceptions.c:513
#14 0x0000000000491468 in tui_command_loop (data=<value optimized out>) at
../../gdb/tui/tui-interp.c:156
#15 0x000000000043e5b9 in captured_command_loop (data=0x0) at ../../gdb/main.c:99
#16 0x00000000004e9884 in catch_errors (func=0x43e5b0 <captured_command_loop>,
func_args=0x0, errstring=0x647c6a "", mask=<value optimized out>)
    at ../../gdb/exceptions.c:513
#17 0x000000000043f0b6 in captured_main (data=<value optimized out>) at
../../gdb/main.c:884
#18 0x00000000004e9884 in catch_errors (func=0x43e5f0 <captured_main>,
func_args=0x7fffd2cf8ea0, errstring=0x647c6a "", mask=<value optimized out>)
    at ../../gdb/exceptions.c:513
#19 0x000000000043e5a4 in gdb_main (args=0x7fffd2cf84a0) at ../../gdb/main.c:893
#20 0x000000000043e576 in main (argc=<value optimized out>, argv=0x7fffd2cf84a0)
at ../../gdb/gdb.c:33
(gdb) 
Comment 2 Jan Kratochvil 2008-04-18 11:52:06 EDT
I have a backport available but still not committed due to failing
regression-tests for the new release in RHTS (Job 20573, Job 20605) and even
standalone but these problems are unrelated to this Bug.

It never worked before, the problem is trying to debug through the exec syscall
and together with threads, you may run /usr/lib/rpm/rpmk on its own instead as a
workaround.  F9 blocker is OK as it is just a backport.

* Wed Apr 16 2008 Jan Kratochvil <jan.kratochvil@redhat.com> - 6.8-4
- Backport fix on various forms of threads tracking across exec() (BZ 442765).

http://sourceware.org/ml/gdb-patches/2008-03/msg00281.html
http://sourceware.org/ml/gdb-cvs/2008-03/msg00114.html
Comment 3 Bill Nottingham 2008-04-29 16:16:18 EDT
Moving to target, this is not a release blocker.
Comment 4 Fedora Update System 2008-05-12 08:23:59 EDT
gdb-6.8-5.fc9 has been submitted as an update for Fedora 9
Comment 5 Fedora Update System 2008-05-13 11:26:00 EDT
gdb-6.8-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.