Bug 442767 - ftp case directive botches mget when mixed case filenames exit
ftp case directive botches mget when mixed case filenames exit
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ftp (Show other bugs)
4.6
All Linux
medium Severity medium
: rc
: ---
Assigned To: Jiri Skala
Ben Levenson
: ZStream
Depends On:
Blocks: 442772 447940
  Show dependency treegraph
 
Reported: 2008-04-16 13:38 EDT by Jeff Bastian
Modified: 2014-11-09 17:31 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the "case" command was used to turn on the remote computer file name case mapping, using the "mget" command to download remote files may have caused the ftp client to overwrite the files on the client machine with the wrong content, or fail when mixed-case file names were used. For example, downloading multiple files may have resulted in a single file, that contained the content of a different file. This has been fixed, and all files are now transferred with their original content as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 07:18:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2008-04-16 13:38:16 EDT
+++ This bug was initially created as a clone of Bug #442710 +++

Description of problem: 
ftp can overwrite files with the wrong content or fail to get/put files when
mixed-case filenames are involved.

Version-Release number of selected component (if applicable):
ftp-0.17-23.EL4

How reproducible: 
always

Steps to Reproduce: 

1.  Login to a linux box and install/start up vsftpd.  
2.  Create the following files in /var/ftp/pub
  * Test1.out1
  * TEST2.OUT2
  * tesT3.Out3

3. Connect to ftp server

ftp> ls
227 Entering Passive Mode (9,67,58,187,198,5)
150 Here comes the directory listing.
-rw-rw-r--    1 503      503            11 Apr 11 15:33 TEST2.OUT2
-rw-rw-r--    1 503      503            11 Apr 11 15:32 Test1.out1
-rw-rw-r--    1 503      503            11 Apr 11 15:33 tesT3.Out3
226 Directory send OK.
ftp> bin
200 Switching to Binary mode.
ftp> prompt
Interactive mode off.
ftp> case
Case mapping on.
ftp> mget *
local: test2.out2 remote: TEST2.OUT2
227 Entering Passive Mode (9,67,58,187,161,53)
150 Opening BINARY mode data connection for TEST2.OUT2 (11 bytes).
226 File send OK.
11 bytes received in 0.0086 seconds (1.3 Kbytes/s)
local: test2.out2 remote: Test1.out1
227 Entering Passive Mode (9,67,58,187,23,178)
150 Opening BINARY mode data connection for Test1.out1 (11 bytes).
226 File send OK.
11 bytes received in 0.0037 seconds (2.9 Kbytes/s)
local: test2.out2 remote: tesT3.Out3
227 Entering Passive Mode (9,67,58,187,72,19)
150 Opening BINARY mode data connection for tesT3.Out3 (11 bytes).
226 File send OK.
11 bytes received in 0.006 seconds (1.8 Kbytes/s)


Actual results:  
local filename for the second 2nd and 3rd files transfered is the same as the
first.  The end result is a single file in the local directory called test2.out2
with the contents of tesT3.Out3

Expected results:  
3 files transfered with their original contents.  Only the file with all
uppercase in the name is translated to lowercase (according to the ftp manpage
at least.)
Comment 6 RHEL Product and Program Management 2008-05-15 15:20:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 Martin Nagy 2008-05-27 04:49:49 EDT
The z-stream bug was resolved, from bug #447940:

An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0507.html
Comment 13 Martin Nagy 2008-05-27 04:52:49 EDT
Since the bug was fixed in z-stream, this bug report will be leaved in the
MODIFIED state until another ftp y-stream errata will be released.
Comment 34 Jaromir Hradilek 2010-07-15 07:26:46 EDT
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
When the "case" command was used to turn on the remote computer file name case mapping, using the "mget" command to download remote files may have caused the ftp client to overwrite the files on the client machine with the wrong content, or fail when mixed-case file names were used. For example, downloading multiple files may have resulted in a single file, that contained the content of a different file. This has been fixed, and all files are now transferred with their original content as expected.
Comment 36 errata-xmlrpc 2010-07-21 07:18:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0548.html

Note You need to log in before you can comment on or make changes to this bug.