Bug 442790 - Ralink RT2x00 - auto bit rate not working
Ralink RT2x00 - auto bit rate not working
Status: CLOSED DUPLICATE of bug 443203
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On: 451422
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-16 16:00 EDT by Ivan Virgili
Modified: 2008-07-08 15:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-08 15:59:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsmod output (4.32 KB, text/plain)
2008-04-16 16:26 EDT, Ivan Virgili
no flags Details

  None (edit)
Description Ivan Virgili 2008-04-16 16:00:22 EDT
With kernels 2.6.24.4-74.fc8 and 2.6.24.4-82.fc8 if the bit rate is set to auto,
then this is stuck to 1 Mb/s with consequent wireless connection very slow.
If I manually set it to 54 Mb/s, then the speed is fine.
As soon as I set it back to auto it slowly goes down to 1 Mb/s.

I am very near the wireless router, therefore that is not the problem.

We had the same issue a few months ago, but it then got sorted.
Comment 1 Ivan Virgili 2008-04-16 16:20:45 EDT
I found the old bug report: 382781
Comment 2 Ivo van Doorn 2008-04-16 16:21:22 EDT
Does 'lsmod' report the presence of rc80211_simple or rc80211_pid ?
Comment 3 Ivan Virgili 2008-04-16 16:26:02 EDT
Created attachment 302669 [details]
lsmod output
Comment 4 Ivan Virgili 2008-04-16 16:27:14 EDT
I cannot find either of them in the lsmod report (see attachment)
Comment 5 Ivo van Doorn 2008-04-16 16:34:33 EDT
John, which rate selection algorithm is being used in Fedora by default?
Comment 6 John W. Linville 2008-04-16 17:05:00 EDT
Should be PID...
Comment 7 Ivan Virgili 2008-05-04 06:16:45 EDT
Installed kernel 2.6.24.6-90.fc8 but... problem not really solved.
The card starts at 1 Mb/s and does not move from there.
If I enter "iwconfig wlan2 rate auto" nothing changes, but "iwconfig wlan2 rate
54M" first and then "wconfig wlan2 rate auto", the card starts working properly
(bit rate gets adjusted depending on the quality of the signal).
I will do a few more tests.
Comment 8 Ivan Virgili 2008-05-04 06:30:43 EDT
Even if you follow the procedure described above, after a while the speed goes
back to 1 Mb/s and does not move from there.
Moreover, even if I manually set the speed at 54 Mb/s, the real speed is
probably not more than 8/11 Mb/s.
Comment 9 Ivan Virgili 2008-05-20 16:15:40 EDT
Installed F9 kernel 2.6.25.3-18.fc9.i686 and problem still happening.
Comment 10 Ra P. 2008-06-25 09:44:42 EDT
with  2.6.25.6-55.fc9 the adapter DOES NOT WORK AT ALL. It simple does not
connect to any network at all, great solution that you RedHat ;-)

here are the details
https://bugzilla.redhat.com/show_bug.cgi?id=451422
Comment 11 John W. Linville 2008-07-08 15:59:21 EDT

*** This bug has been marked as a duplicate of 443203 ***

Note You need to log in before you can comment on or make changes to this bug.