This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 442802 - ipa-server-install ldappasswd fail
ipa-server-install ldappasswd fail
Status: CLOSED WORKSFORME
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
unspecified
i386 Linux
high Severity high
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks: 429034
  Show dependency treegraph
 
Reported: 2008-04-16 17:21 EDT by Harry Noble
Modified: 2015-01-04 18:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-29 10:41:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harry Noble 2008-04-16 17:21:54 EDT
Description of problem:
During install ldappasswd fails to change admin password leaving kinit admin to
fail with Preauthentication failed due to password not being the same.

log message has: ldap_start_tls_s failed: (Can't connect to the LDAP server)
DEBUG Unable to set admin password Command '/usr/lib/mozldap/ldappasswd -D
cn=Directory Manager -w example -P /etc/dirsrv/slapd-EXAMPLE-COM//cert8.db -ZZZ
-s example uid=admin,cn=sysaccounts,cn=etc,dc=example,dc=com' returned non-zero
exit status 91

Version-Release number of selected component (if applicable):
current ipa-server version from testing.
ipa-server-install --version reports ipa-server-install .1


Additional info:
Fixed by adding "" around cn=Directory Manager
Comment 2 Rob Crittenden 2008-05-05 10:59:59 EDT
Just to be clear, you did something like this?

diff --git a/ipa-server/ipaserver/dsinstance.py b/ipa-server/ipaserver/dsinstanc
index a56a8a8..d217123 100644
--- a/ipa-server/ipaserver/dsinstance.py
+++ b/ipa-server/ipaserver/dsinstance.py
@@ -361,7 +361,7 @@ class DsInstance(service.Service):
         else:
             app = "/usr/lib/mozldap/ldappasswd"
         args = [app,
-                "-D", "cn=Directory Manager", "-w", self.dm_password,
+                "-D", "\"cn=Directory Manager\"", "-w", self.dm_password,
                 "-P", dirname+"/cert8.db", "-ZZZ", "-s", password,
                 "uid=admin,cn=sysaccounts,cn=etc,"+self.suffix]
         try:
Comment 3 Harry Noble 2008-05-05 15:22:11 EDT
No I run the code by itself did not patch the source.
Comment 4 Rob Crittenden 2008-05-05 15:58:36 EDT
What I meant was: did you make a similar change to dsinstance.py on your system
to make the installation successful?
Comment 5 Rob Crittenden 2008-05-09 14:09:08 EDT
I can't reproduce this behavior. Is it possible for you to try the install again
and see if it happens again for you?

Did you install this from source or from the Fedora repos?
Comment 6 Rob Crittenden 2008-05-13 22:57:56 EDT
Sorry, I had set the NEEDINFO wrong.

I can't reproduce this and need more details on what it is you changed to make
it work on your system.
Comment 7 Rob Crittenden 2008-05-29 10:41:53 EDT
Closing this for now, I can't reproduce this. It may have been fixed as a
side-effect of another change, I can't be sure.

Note You need to log in before you can comment on or make changes to this bug.