This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 442803 - fedora 9 or rawhide should match LSB 3.2
fedora 9 or rawhide should match LSB 3.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Hao Liu
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-16 17:23 EDT by Mats Wichmann
Modified: 2009-04-24 02:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: redhat-lsb3.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-24 02:20:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to update redhat-lsb (expanded) tarball (23.40 KB, patch)
2008-04-29 16:59 EDT, Mats Wichmann
no flags Details | Diff

  None (edit)
Description Mats Wichmann 2008-04-16 17:23:13 EDT
redhat-lsb should provide the deps for LSB 3.2, it works for LSB 3.2 at least as
well as earlier Fedora versions did for 3.1 (this is not the same as asking for
Fedora to be certified!).  I have an updated copy available that has made the
appropriate database queries matching LSB 3.2 requirements - can build a package
from this that seems to work fine.
Comment 1 Mats Wichmann 2008-04-29 16:59:41 EDT
Created attachment 304156 [details]
patch to update redhat-lsb (expanded) tarball

Since there's been no uptake, I'm attaching a patch.  Note this is not a
patch-to-add-to-the-package, but rather one to bring forward the expanded
tarball to a new version.  This package is a little odd since it does work to
extract data from a local copy of the LSB database and uses that to build a new
specfile, it means we have to start the modifications "at the top" as it were. 
Anyway - this works for me and should be a good starting point.  I'm
successfully using the resulting package on f9.
Comment 2 Bug Zapper 2008-05-14 05:33:06 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Lawrence Lim 2008-05-30 01:33:25 EDT
Sorry for the delay Mats. I will Liu Hao helping me including the patch into the
package.
Comment 4 Hao Liu 2008-08-28 02:31:48 EDT
Fixed in the redhat-lsb3.2-2

Note You need to log in before you can comment on or make changes to this bug.