Bug 442833 - firefox - 2.0.0.13-1.fc7.x86_64 SIGSEGV on startup
firefox - 2.0.0.13-1.fc7.x86_64 SIGSEGV on startup
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 01:20 EDT by fred2
Modified: 2008-06-16 23:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 23:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested debug output (but see comments - may be incomplete) (1.92 KB, text/plain)
2008-04-18 15:59 EDT, fred2
no flags Details

  None (edit)
Description fred2 2008-04-17 01:20:28 EDT
Description of problem:
recent upgrade (via yum) of firefox fc7 to new version results in SIGSEGV at 
startup. previous version ( Feb 16 14:37:44 Updated: firefox - 2.0.0.12-
1.fc7.x86_64) worked fine. 
no workaround discovered yet, so cannot use firefox.


Version-Release number of selected component (if applicable):
non-working (new): 2.0.0.13-1.fc7.x86_64
working (previous): 2.0.0.12-1.fc7.x86_64

How reproducible:
100%, whether i use htmlview, or /usr/lib64/firefox-2.0.0.13/firefox-bin 
directly

Steps to Reproduce:
1. htmlview. or run firefox-bin
2.
3.
  
Actual results:
$ gdb /usr/lib64/firefox-2.0.0.13/firefox-bin
GNU gdb Red Hat Linux (6.6-16.fc7rh)

...
(no debugging symbols found)
(no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 46912506956672 (LWP 3839)]
0x000000341a20a645 in _dl_relocate_object () from /lib64/ld-linux-x86-64.so.2

details of ld lib referenced by segv:
$ ll /lib64/ld-linux-x86-64.so.2
lrwxrwxrwx 1 root root 9 2007-07-13 09:20 /lib64/ld-linux-x86-64.so.2 -> ld-
2.6.so

$ ll /lib64/ld-2.6.so
-rwxr-xr-x 1 root root 134384 2007-07-08 04:57 /lib64/ld-2.6.so

$ nm /lib64/ld-2.6.so | grep relocate_object
000000341a20a270 t _dl_relocate_object


Expected results:
(prior firefox worked as expected, no segv)


Additional info:

$ uname -a
Linux 2.6.23.15-80.fc7 #1 SMP Sun Feb 10 16:52:18 EST 2008 x86_64 x86_64 x86_64 
GNU/Linux

yum.log (not clear if immediately preceding Gconf2 error affects firefox 
install, multi-pkg update was done):
...
Apr 12 07:18:24 Updated: gnome-screensaver - 2.18.2-4.fc7.x86_64
Apr 12 07:18:24 Failed to load file "/etc/gconf/gconf.xml.defaults/%gconf-tree-
ta.xml": Error on line 4005 char 205: Invalid UTF-8 encoded text

Apr 12 07:18:38 Updated: firefox - 2.0.0.13-1.fc7.x86_64
Apr 12 07:18:39 Updated: gnome-python2-extras - 2.14.3-9.fc7.x86_64
...
Comment 1 Matěj Cepl 2008-04-17 09:34:06 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please install firefox-debuginfo; in order to do this you have to enable
-debuginfo repository.

	yum install --enablerepo=\*debuginfo firefox-debuginfo

(if you use x86_64 firefox, install firefox-debuginfo.x86_64  package).

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Christopher Aillon 2008-04-17 10:14:50 EDT
Also, 2.0.0.14 should be making it's way out to mirrors very soon.
Comment 3 fred2 2008-04-18 15:59:30 EDT
Created attachment 302933 [details]
requested debug output (but see comments - may be incomplete)

(1) check (& install) debuginfo pkg:
$ yum --enablerepo=\*debuginfo list available '*irefo*'
Available Packages
firefox.i386				 2.0.0.13-1.fc7 	updates        

firefox-32.x86_64			 0.0.1-5.fc7		fedora	       

firefox-debuginfo.x86_64		 3.0-0.54.beta5.fc9    
development-debu
firefox-devel.x86_64			 2.0.0.13-1.fc7 	updates        

firefox-devel.i386			 2.0.0.13-1.fc7 	updates     

$ rpm -qa|grep firefox
firefox-2.0.0.13-1.fc7
firefox-debuginfo-3.0-0.54.beta5.fc9

(2) run firefox w/ -g option
$ which firefox
/usr/bin/firefox
$ file /usr/bin/firefox
/usr/bin/firefox: Bourne shell script text executable
$ firefox -g
Segmentation fault

$ uname -m
x86_64
[so, i think the script sets:
MOZ_LIB_DIR="/usr/lib64"
$MOZ_LIB_DIR/firefox-2.0.0.13/firefox-bin ]

so, maybe i need to run firefox-bin directly:
$/usr/lib64/firefox-2.0.0.13/firefox-bin -g
Segmentation fault
hmm, doesn't seem to recognize -g option? 
(note: --help does not list any -g 'Mozilla option' either.)
not clear whether inconsistency in pkg versions might be an issue.

so, run under gdb (not sure if backtrace info is due to
debuginfo, since i did not check it prior to installing 
debuginfo pkg).

in any case, backtrace stdout is attached.
(if more info is needed, i'll be offline for the next week or so).
Comment 4 Bug Zapper 2008-05-14 11:26:54 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2008-06-16 23:06:33 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.