Bug 442840 - MyPasswordSafe fails with free() while opening a safe
MyPasswordSafe fails with free() while opening a safe
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: MyPasswordSafe (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ralf Ertzinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2008-04-17 02:30 EDT by Ilkka Tengvall
Modified: 2009-07-14 12:13 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 12:13:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace spit out from MyPasswordSafe (8.52 KB, text/plain)
2008-04-17 02:30 EDT, Ilkka Tengvall
no flags Details
bactrace from gdb with debug symbols (3.97 KB, text/plain)
2008-05-14 04:38 EDT, Ilkka Tengvall
no flags Details
using obsolete qt-mt while building -> fails (4.83 KB, text/plain)
2008-05-19 02:30 EDT, Ilkka Tengvall
no flags Details

  None (edit)
Description Ilkka Tengvall 2008-04-17 02:30:56 EDT
Description of problem:
MyPasswordSafe fails to open the main window after initial safe-file selection.
Glibc error with free() is caught.

Version-Release number of selected component (if applicable):

MyPasswordSafe-0.6.7-4.20061216.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Start MyPasswordSafe
2. click ok to licence window
3. select open existing safe and select the safe
4. type in the password and click ok

Actual results:
Program dies with glibc error caught.

Expected results:
To open the main window with password file open.

Additional info:
Comment 1 Ilkka Tengvall 2008-04-17 02:30:56 EDT
Created attachment 302707 [details]
backtrace spit out from MyPasswordSafe
Comment 2 Ralf Ertzinger 2008-04-18 11:30:58 EDT
Works for me on x86, I don't have a 64bit machine to test on.
Comment 3 Ilkka Tengvall 2008-04-21 05:54:48 EDT
Some upgrade on this... it seems this has something to do with my password
database file. It opens just fine with other programs, and even with
MyPasswordSafe on Fedora 8 (MyPasswordSafe-0.6.7-1.20061216.fc8).

But if I open the program by creating a new file instead of opening this
existing of mine, it works. Even if I create a new pw entry in the fresh file,
save it, and re-open the program using that .dat file, it works. So whoever
tries this most probably sees it working just fine unless using some old
pre-existing password database.

The database format (file type) I use is this Password Safe 2.0 *.dat.

This file of mine can be opened in fedora 9 by using pwsafe cmdline prog
(pwsafe-0.2.0-4.fc9.x86_64).
Comment 4 Ralf Ertzinger 2008-04-27 10:04:54 EDT
Could you probably send me a file which makes MyPasswordSafe crash, if you are
able to create a new one?
Comment 5 Ilkka Tengvall 2008-04-28 08:50:36 EDT
I tried doing it, but I can't recreate such a file. I tried moving the new file
around and modifying it on the machines I normally use for the original file,
but no-go. They work. It's only the real passwd file I use that crashes under
FC9 -64bit. The same file still works under FC8, Ubuntu, mac, and N800.

I need to find another program to use in Fedora. Too bad I can't use revelation
either, since http://svn.codepoet.no/revelation/ticket/172 and many similar
preventing usage of it.

Sorry, I don't know how to make a new file for it which would crash it.
Comment 6 Ilkka Tengvall 2008-05-14 04:38:08 EDT
Created attachment 305338 [details]
bactrace from gdb with debug symbols

I installed all necessary -debug rpms to get decent backtrace. The program
still fails in just released fedora 9. See attachment.
Comment 7 Bug Zapper 2008-05-14 05:34:18 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Ilkka Tengvall 2008-05-19 02:30:44 EDT
Created attachment 305905 [details]
using obsolete qt-mt while building -> fails

Re-building of MyPasswordSafe also fails. It is missing some dependancies, and
scripts use some old qt setup scripts. See attachement.

This command produces nothing, there is no package qt-mt:

/usr/bin/pkg-config --variable=prefix qt-mt
Comment 9 Bug Zapper 2009-06-09 20:13:50 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-07-14 12:13:45 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.