Bug 442883 - Add super-H(sh3,4) architecture support.
Add super-H(sh3,4) architecture support.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: star (Show other bugs)
rawhide
sh4 Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 07:58 EDT by CHIKAMA Masaki
Modified: 2009-01-25 08:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-12 08:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CHIKAMA Masaki 2008-04-17 07:58:19 EDT
Description of problem:
 This patch enables to compile on sh3,sh4 architecture.
I know it's ugly that all package which include a part of cdrecord
has different solution for this problem.

See also #441824, #441823 .

--- star.spec.org       2008-04-16 23:50:17.000000000 +0900
+++ star.spec   2008-04-16 23:51:00.000000000 +0900
@@ -28,7 +28,7 @@
 %endif
 %patch3 -p1 -b .changewarnSegv
 
-for PLAT in %{arm} x86_64 ppc64 s390 s390x; do
+for PLAT in %{arm} x86_64 ppc64 s390 s390x sh3 sh4 sh4a; do
         for AFILE in gcc cc; do
                 [ ! -e RULES/${PLAT}-linux-${AFILE}.rul ] \
                 && ln -s i586-linux-${AFILE}.rul RULES/${PLAT}-linux-${AFILE}.rul
Comment 1 Peter Vrabec 2008-05-12 08:36:58 EDT
done.(star-1.5a84-5.fc10)
Comment 2 Jörg Schilling 2009-01-25 08:19:42 EST
The "problem" you believe to see is a result of using a
make program with limited funtionality.

Just use "smake" and it automagically compiles
on all platforms because of the automake features
that are implemented in smame.

Note You need to log in before you can comment on or make changes to this bug.