Bug 442884 - mrtg perl errors SNMP_Session.pm at Exporter.pm
mrtg perl errors SNMP_Session.pm at Exporter.pm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mrtg (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 08:09 EDT by David Timms
Modified: 2008-04-18 09:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 09:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages during startup. (1.67 KB, text/plain)
2008-04-17 08:09 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2008-04-17 08:09:17 EDT
Description of problem:
While trying to track down a selinux denial, I tried to run manually run the 5
minute interval scheduled mrtg command from /etc/cron.d/mrtg 

Version-Release number of selected component (if applicable):
mrtg-2.15.1-8.fc9.i386
perl-SNMP_Session-1.08-4.fc9.noarch

How reproducible:
Two F8>F9Beta>2008-04-17 systems.

Steps to Reproduce:
1.  LANG=C LC_ALL=C /usr/bin/mrtg /etc/mrtg/mrtg.cfg --lock-file \
/var/lock/mrtg/mrtg_l --confcache-file /var/lib/mrtg/mrtg.ok
  
Actual results:
warnings about redefined and prototype mismatch about AF_INET_6, PF_INET_6
see attached.

Expected results:
Silently complete.

Additional info:
May be due to changes in perl (perl-5.10.0-20.fc9.i386), since
on F8 (perl-5.8.8-38.fc8) this did not occur.

There are newer stable releases available.
http://oss.oetiker.ch/mrtg/pub/?M=D
[   ] mrtg-2.16.1.tar.gz         17-Feb-2008 11:30  1.0M
[   ] mrtg-2.16.0.tar.gz         06-Feb-2008 15:36  1.0M
[   ] mrtg-2.15.2.tar.gz         29-Apr-2007 09:11  1.0M
[   ] mrtg-2.15.1.tar.gz         01-Feb-2007 00:41  1.0M

Changes 2.15.2, 2007-04-29
--------------------------
...
From: Mike Mitchell Mike.Mitchell sas.com
* Updated Net_SNMP_util module (error messages)

Seems like it may resolve this, but I have not tested that.

I don't know if mrtg fails to run properly when this occurs.
Comment 1 David Timms 2008-04-17 08:09:17 EDT
Created attachment 302737 [details]
messages during startup.
Comment 2 Vitezslav Crhonek 2008-04-17 08:17:03 EDT

*** This bug has been marked as a duplicate of 437681 ***
Comment 3 Tom "spot" Callaway 2008-04-18 08:08:52 EDT
Before (2.15.1-8):
[spot@localhost devel]$ sudo LANG=C LC_ALL=C /usr/bin/mrtg /etc/mrtg/mrtg.cfg
--lock-file /var/lock/mrtg/mrtg_l --confcache-file /var/lib/mrtg/mrtg.ok
Constant subroutine SNMP_Session::AF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 140
Prototype mismatch: sub SNMP_Session::AF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 140
Constant subroutine SNMP_Session::PF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 140
Prototype mismatch: sub SNMP_Session::PF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 140
Constant subroutine SNMPv1_Session::AF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 594
Prototype mismatch: sub SNMPv1_Session::AF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 594
Constant subroutine SNMPv1_Session::PF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 594
Prototype mismatch: sub SNMPv1_Session::PF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/../lib64/mrtg2/SNMP_Session.pm line 594
Constant subroutine main::AF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/mrtg line 101
Prototype mismatch: sub main::AF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/mrtg line 101
Constant subroutine main::PF_INET6 redefined at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/mrtg line 101
Prototype mismatch: sub main::PF_INET6 () vs none at
/usr/lib/perl5/5.10.0/Exporter.pm line 66.
 at /usr/bin/mrtg line 101

After (2.16.1-1): 
[spot@localhost devel]$ sudo rpm -Uvh
/home/spot/cvs/sandbox/mrtg/devel/x86_64/mrtg-2.16.1-1.fc9.x86_64.rpm
Preparing...                ########################################### [100%]
   1:mrtg                   ########################################### [100%]
[spot@localhost devel]$ sudo LANG=C LC_ALL=C /usr/bin/mrtg /etc/mrtg/mrtg.cfg
--lock-file /var/lock/mrtg/mrtg_l --confcache-file /var/lib/mrtg/mrtg.ok
[spot@localhost devel]$

2.16.1 doesn't fix this bug directly, but I updated anyway, so that the patch
which does fix this bug would be against the latest from upstream.

Please confirm that this package resolves the issue for you:
http://koji.fedoraproject.org/koji/buildinfo?buildID=46559

If so, I'll ask for it to be tagged for F-9.
Comment 4 David Timms 2008-04-18 09:37:19 EDT
I grabbed the i386 build and did a before and after test with 
$ yum localupdate mrtg-2.16... , 

and on the other machine with 
$ yum remove mrtg
$ yum localinstall mrtg-2.16...

Both machines now have no output when the above command from /etc/cron.d/mrtg is
run manually at the command line.

Note that I haven't performed a functionality test of the package at all.
Changed to resolved rawhide, since there is no resolved koji...

Note You need to log in before you can comment on or make changes to this bug.