Bug 442887 - Old 5.0 httpd.conf overwritten and not saved upon install of 5.1
Old 5.0 httpd.conf overwritten and not saved upon install of 5.1
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Pazdziora
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 08:37 EDT by Jan Pazdziora
Modified: 2008-05-06 13:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 08:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2008-04-17 08:37:58 EDT
Description of problem:

In
http://www.redhat.com/mailman/private/rhn-satellite-users/2008-April/msg00108.html
, the customer reports:

FYI regarding http://kbase.redhat.com/faq/FAQ_49_9020.shtm
In the 5.0.1 -> 5.1 migration, httpd config moves from /etc/httpd to
/etc/rhn/satellite-httpd
(in case you modify your httpd.conf)

Though they transition to use the new directory, your old httpd.conf is
still overwritten ; and in my one test install *not* saved in
/etc/sysconfig/rhn/backup-<date stamp> as it has been with prior installs.

Version-Release number of selected component (if applicable):

Satellite 5.1.0.

How reproducible:

Did not try to verify, just took report from the mailing list.

Steps to Reproduce:
1. Have Satellite 5.0.
2. Do some custom changes to httpd.conf.
3. Upgrade to 5.1.
4. Check to see if the old /etc/httpd/httpd.conf was stored somewhere.
  
Actual results:

The file overwritten, custom changes lost.

Expected results:

The file not overwritten at all, or saved in /etc/sysconfig/rhn/backup-<date stamp>.

Additional info:
Comment 1 Jan Pazdziora 2008-05-06 08:06:07 EDT
adelton | cliff: I believe the problem with the httpd.conf might be that we do
rpm -e rhn-apache rather early in the installer. So by the time we populate /etc
from /etc/sysconfig/rhn-satellite-prep, there is nothing in /etc/httpd/conf to
be saved.
adelton | cliff: So the issue seems to be there.
cliff | one of the irst steps in an 'upgrade' we document is to 'perform a
backup'? :)
adelton | cliff: I know.
cliff | done... closed :)

Note You need to log in before you can comment on or make changes to this bug.