Bug 442889 - yum update traceback - UnboundLocalError
yum update traceback - UnboundLocalError
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
i386 Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 443025 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 09:00 EDT by David Timms
Modified: 2014-01-21 18:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 09:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum update -d 10 with traceback (8.95 KB, text/plain)
2008-04-17 09:00 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2008-04-17 09:00:03 EDT
Description of problem:
A traceback occured during yum update

Version-Release number of selected component (if applicable):
yum-3.2.14-2.fc9.noarch

How reproducible:
adding -d 10 to same command generated the same tb.

Steps to Reproduce:
1. time yum -y update
  
Actual results:
...
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 521, in _genDeptup
    (misc.share_data(r_e), misc.share_data(r_v),
UnboundLocalError: local variable 'r_e' referenced before assignment

Expected results:
update worked.

Additional info:
Since the update package group had yum in it, I yum -y update yum, OK.
new is yum-3.2.14-9.fc9.noarch
Now the original command now works OK. Although it already now WFM, filing in
case I was just lucky...
Comment 1 David Timms 2008-04-17 09:00:04 EDT
Created attachment 302745 [details]
yum update -d 10 with traceback
Comment 2 Seth Vidal 2008-04-17 09:18:14 EDT
you're not lucky, but thanks.

it was broken in -2
fixed in like -5
definitely fixed in -10 which is in rawhide.

thanks
Comment 3 Seth Vidal 2008-04-18 08:08:04 EDT
*** Bug 443025 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.