Bug 442899 - matchpathcon_filespec_add: conflicting specifications for /sbin/mkfs.gfs and /sbin/gfs_mkfs
matchpathcon_filespec_add: conflicting specifications for /sbin/mkfs.gfs and ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs-utils (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Robert Peterson
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-17 10:22 EDT by Milan Zazrivec
Modified: 2010-01-11 22:34 EST (History)
2 users (show)

See Also:
Fixed In Version: u2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-15 11:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setfiles output (1003 bytes, text/plain)
2008-04-17 10:22 EDT, Milan Zazrivec
no flags Details

  None (edit)
Description Milan Zazrivec 2008-04-17 10:22:24 EDT
Description of problem:
Running setfiles command produces several error messagess complaining about
conflicting specifications for several files in /sbin

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-131.el5

How reproducible:
Always

Steps to Reproduce:
1. # setfiles -vqn /etc/selinux/targeted/contexts/files/file_contexts /sbin/
  
Actual results:
Attachment
Comment 1 Milan Zazrivec 2008-04-17 10:22:24 EDT
Created attachment 302751 [details]
setfiles output
Comment 2 Daniel Walsh 2008-04-17 11:04:06 EDT
The problem here is there are multiple paths to the same file,  from an SELinux
point of view, it would be much easier if these were all symbolic links versus
hard links.   

Comment 3 Robert Peterson 2008-04-17 12:44:49 EDT
The e2fs utils use hard links as well.  Are you saying this is wrong?

[root@bigi /home/bob]# stat /sbin/e2fsck | grep Inode
Device: fd00h/64768d    Inode: 196694      Links: 3
[root@bigi /home/bob]# stat /sbin/fsck.ext2 | grep Inode
Device: fd00h/64768d    Inode: 196694      Links: 3
[root@bigi /home/bob]# stat /sbin/fsck.ext3 | grep Inode
Device: fd00h/64768d    Inode: 196694      Links: 3
Comment 4 Robert Peterson 2008-04-17 12:48:22 EDT
Clarification: The gfs-utils and gfs2-utils were originally symlinks
and I was asked specifically to change them to hard links to match ext3
in bug #286211.  I personally don't care; I just need to know which is
proper.  Since gfs and gfs2 are following in the footsteps of ext3,
if it's valid for ext, shouldn't it be valid for gfs as well?
Comment 7 RHEL Product and Program Management 2008-06-04 18:45:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Daniel Walsh 2008-07-15 11:31:28 EDT
I believe these are fixed in U2.

Note You need to log in before you can comment on or make changes to this bug.